Help with VD and Sibelius

Need help. I've exhausted the vd readme and help files and still having trouble getting soundfonts to play back on Sibelius. I am able to get the sounds to playback on the keyboard in Audio HQ (soundblaster live), though. I used a midi keyboard to enter notes on the vd template.sib file. Any advice? Thanks.
It sounds like your MIDI settings may not be set correctly in Sibelius. Be sure you've clicked on the "reset sounds" button in Sibelius mixer window.

In AudioHQ, you should take note of what is set as your "soundfont device". This is what you should have chosen in Sibelius' mixer window as the "device" for each of your battery tracks. You need to set up each staff's device individually in Sibelius, but once you've done that, you can save the Sibelius file, and use it as a template for future projects.

Feel free to check back in with us here if this doesn't solve your problems.

Adam
Thanks for the reply, Adam... My soundfont audio hq setting is "SB Live! (1460)". In Sibelius the only device in the drop down box that comes close to the same device in audio hq is "SB Live! MIDI Out (1460)". This should be the one I use, correct?

Here are the other options in the drop down...

Creative S/W Synth
A: SB Live! MIDI Synth
B: SB Live! MIDI Synth

Please advise. thanks
drumsauxperc,

I'm not sure. I'd try setting your Audiohq Soundfont device to "A:SB Live! MIDI Synth." Once you've done that, also check to see which bank you've loaded your VDrumline soundfont bank into (in the "configure bank" section of audiohq).

Then, go into the VDrumline template in Sibelius, and open your mixer window. Click on the snare track (for example) and select "A:SB Live! MIDI Synth" as your device, and in the "bank high" field, set it to the bank you loaded the VDrumline bank into in AudioHQ ("1" for example). Once you've done this, you should also be sure to accurately set the program number in Sibelius' mixer window. Use "0" for snare, 1 for tenor, 5 for bass, and 7 for cymbals. Just to be sure, you might also want to click the "display" button in Sibelius mixer window and set it to list program numbers as 0-127. Most likely, that's already set correctly, but you never know.

You'll need to repeat these steps for each instrument in the mixer window (snare, tenor, bass, cyms). Once you've done that, save the file as a template for future use, and you won't have to always mess with it like this.

let me know if this works for you.
AB
Adam,

I seem to be having the same problem. I did everything as instructed above, but I continuously get the Piano sounds in place of the snare, tenor, bass, and cymbal sounds. Any ideas?
Check to make sure that the "MIDI Thru" box is checked in the DEVICE window in Sibelius. Let me know if that helps.

AB
yes the "MIDI Thru" box has been checked, and still nothing...any other ideas?
mollydrummer - please let me know about the following settings in your system:

Please let me know the following:
Where are your VDrumline sounds loaded?
What operating system are you using?
What version of Sibelius are you using?

In the Sibelius MIXER:
-Did you click "reset sounds"?
-What is each staff (track) set to in the DEVICE popup?
-What is each staff set to in the CHANNEL field?
-What is each staff set to in the BANK field?
-What is each staff set to in the PROGRAM field?
-What is each staff set to in the BANK field

Thanks. We'll get this figured out.

AB
Where are your VDrumline sounds loaded? ---[b]in my Creative Labs Soundfont Bank Manager[/b]
What operating system are you using? [b]---Windows XP Home Edition[/b]
What version of Sibelius are you using? --[b]-Sibelius 2.0[/b]

In the Sibelius MIXER:
-Did you click "reset sounds"? [b]--YES[/b]
-What is each staff (track) set to in the DEVICE popup[b]?---SB Audigy MIDI Port [A400][/b]
-What is each staff set to in the CHANNEL field?[b] ---Each channel in each track is set to 1[/b]
-What is each staff set to in the BANK field? [b]---For all tracks, Bank High and Bank Low are OFF[/b]
-What is each staff set to in the PROGRAM field? [b]---SNARE: 0 TENORS: 1 BASS: 5 CYMBALS: 7[/b]

I dunno maybe I just need to do everything over but I would still have no idea what I'm doing, Thanks for your help!

-moldydrummer[/b]
Just making sure you know the last post was from me!

-moldydrummer
OK. Thanks for the detailed info molllydrummer. It'll really help us figure this out. It definitely looks like some of your settings are off. But first, I have a few more things for you to look into:

In your Soundfont Bank Manager, when you loaded the sounds, you should have loaded them into a specific bank. Oftentimes, your soundcard's default GM sounds will be loaded into bank 000. For this reason, it's recommended that you load your VDrumline.sf2 into BANK 001. This is especially important if you want to still have access to your other general midi sounds like brass and chromatic percussion.

Once you have verified that VDrumline is loaded into bank 001 in your soundfont bank manager, go to the Sibelius Mixer and change the following settings:
Snare: bank high=1
Tenor: channel=2, bank high=1
Bass: channel=3, bank high=1
Cymbals: channel=4, bank high=1

Also, click the DISPLAY button and make sure programs are listed as:
0-127. This may already be correct, but it's good to double check.

Make those changes, and let me know if you have any different results. There's a chance you may need to alter the "soundfont device" in your soundfont bank manager, so that it corresponds to the same "device" that's selected for each staff in the mixer window. Let me know how it works.

AB
Adam,

I really appreciate all of your help with this. Unfortunately, I feel as if I keep taking a wrong step while doing your instruction. I did change my Soundfont Device to SB Audigy Synth B [A400] for both the soundfont bank and the "Device" field in the Mixer window in Sibelius. When I try to load the sounds into my Soundfont bank, specifically bank 001, it erases ALL of the other sounds in my bank, so now 001 reads as "001 VDRUMLINE FULL" and the rest of the banks like 002, 003, 004 and so forth, read "EMPTY"
A second problem is when I go to the Mixer window in Sibelius. In the Mixer, I have a "Bank High", and a "Bank Low" If I were to change one of these from 0 to 1 (for example the snares) the "Sound" field becomes erased or blank, it doesn't say "Snare Line" anymore. This happens to all of the tracks when I try to change the Bank High or Low to different numbers.
Like I said I really appreciate your help, and I'm sorry to keep bugging you about this, but I just don't get it!
Moldydrummer,
Don't get confused between BANKS and PROGRAMS in your soundfont bank manager. In most cases, bank 000 would be set to all the card's default general midi sounds, and bank 001 would host your Vdrumline soundfont bank. The rest of the banks can be empty, and that's not a problem.

About the sounds disappearing in Sibelius: I should have mentioned this before. Just ignore that "sound" field. It's really only there as a convenience, but if you manually alter settings below, it'll alter what that menu says. This won't have any affect on your ability to playback.

Don't worry about asking these questions. That's what this forum is for! :)

AB
Adam,

Ok now when I compose I get the sounds! but when I do playback I get nothing... ALMOST THERE!!
Great - I'm glad we're getting close. I'm not sure this will fix the playback problem, but try going into your Windows Control Panel > Sounds and Audio Devices > Audio. In Default MIDI playback device, set it to your soundblaster card.

Let me know if that helps.
AB
yep all set now! But one more thing, how will be possible for me to play my normal sounds in sibelius, because now when i try to playback melodic files, I get nothing
Login or Signup to post a comment