USB MIDI Keyboard and Mac set-up

I am running Mac OSX10.2.8, Kontakt, Sibelius 3, and Version Tracker's MIDI Patchbay. Everything works nicely. I have added an M-Audio Keystation 49e USB MIDI keyboard. How do I get it to work? How do I configure the MIDI Patchbay settings, Kontakt set-up, and the Sibelius Devices and Mixer?

Thanks for thinking about this.

- Dan
As discussed before, the chorusing phasing sound is created because Kontakt is receiving input twice - once from Sibelius (via midi patchbay), and once from the keyboard itself. If there's a way to set your keyboard to input via an unused midi channel (say channel 16), my guess is you won't hear that weird chorusing sound.

This is also the reason you're hearing snare sounds upon inputting in other staves. You'll hear the cymbal sound (for example), because Sibelius sends its midi thru to Kontakt. You hear the snare sound because Kontakt is receiving input from channel 1 on your keyboard. You should either set your keyboard to transmit on an unused midi channel, or turn the Keystation to "off" on the MIDI-IN within Kontakt.

The bar number problem is easy to fix. Go to the "view" menu and ensure that "view hidden objects" is selected. If it is, you should see a little gray 0 (zero) above the time signature in the first bar. Click on it, and delete it. This should solve your numbering problem.

Hope this helps,
AB
AB,


I solved my previous input problem by selecting "On" for the Keystation in the MIDI set-up pane of Kontakt. I leave this set even though it produces a chorus effect during snare input. Toggling it seems to randomly create input problems such as the silencing I previously experienced. Why do only the Snare sounds produce the chorus?

Two more questions:

1) When inputting Tenor, Bass, and Cymbal notes, some of the notes have have snare sounds attached to them. For example, when inputting a Cymbal "Scratch Out ", C#4 on the Keymap, C#3 on my Keystation, I also hear a Snare C#4 "Felts Left" according to the Keymap. When I play back the sound the snare sound is gone. How do I get rid of this snare sound during input?

2) Regarding bar numbers, on the updated Sibelius templates - creating bar numbers for every bar places the number one at the beginning of the second bar. Any ideas how to get number one, and the subsequent numbers correct, at the beginning of bar one?


Thanks.

- Dan
Dan,
Sorry to hear of your troubles. I'm a bit stumped about why you weren't able to successfully copy the cymbal music from the past template into the new template. The notehead mapping should be the same.

If all your sounds are still inactive, you might double check all the settings in the "devices" window to ensure they are correct. Also in the mixer, hit "reset sounds" and make sure each staff is setup as expected.

Also, just to be sure...be sure you've launched MIDI Patchbay BEFORE you've launched Sibelius. Perhaps that may have been the problem?

AB
Adam,

I have followed your instructions. Everything was working smoothly. Then...
After updating to the newest template, I copied some snare, tenor, and bass parts from the VD CD Sibelius template into the updated template. Everything was good. Then I copied a cymbal part and it would not play back. Clicking on individual notes produced no sound. Then, the entire score would not playback. I shut everything down, set it all back up, and still no sound during playback. Interestingly, I tried inputing notes with the keystation on the cymbal stave and I heard the snare patches. But this sound was only during input, nothing during playback.

Any ideas as to what the problem may be?

It was all humming along so nicely . . . .

- Dan
Dan,

The chorusing effect you're hearing is most likely occurring because Kontakt is set to receive MIDI-IN from both your Keystation as well as MIDI Patchbay. Make sure it's ONLY set to "on" for Midi Patchbay when you're playing back from your notation program.

However, if you just want to noodle around on your keyboard to hear the sounds (outside of Sibelius), you'd have to switch MIDI-IN back to "on" in Kontakt.

If you can't open the Sibelius templates, you might want to be sure you've upgraded to the latest version from Sibelius (currently 3.1.3). Updates can be downloaded from Sibelius at http://www.sibelius.com

If that doesn't do it (you may even want to try this first), try opening the files from within Sibelius. With Sibelius open, select "open" from the file menu, then navigate to the template you want to open. If it doesn't look available, be sure to enable (in this window) "all file types".

Your soundsets folder should be found here:
Macintosh HD>Applications>Sibelius 3>Sounds

The three soundset files included with the templates should be copied into that folder.

hope this helps,
AB
Adam,

I managed to input notes with the Keystation. However, the sounds seem to be processed (sounds like a chorus effect) in some way. Any thoughts as to why this may be?

Also, regarding the new templates, I could not open them - No default application to open the files. Are there new templates specifically for OSX? There is an empty folder called Sibelius Sound Sets, but that is all the OSX folder contains.

Thanks for your help so far.

- Dan
Be sure you're using the latest Sibelius templates from Tapspace. Get them here:
https://www.tapspace.com/vdrumlinesupport.html

Be sure you've installed the M-Audio Keystation 49e driver that came with the keyboard.

In Sibelius (in the devices window), your MIDI patchbay should be selected as the default output device, with the (giga, kontakt, etc) sound set selected from the sound set column.

Also in the devices window, you should highlight the M-Audio Keystation as your input device. This will appear if you've properly installed the driver for your keyboard. When you've highlighted it, tapping on the keyboard should illuminate the little meter so you know Sibelius is receiving info from it.

Hope this helps,
AB
Login or Signup to post a comment