VD2 and Sibelius on PC - Playback problems

I am having some issues with playback with Sibelius and VD2. When I use my midi keyboard with VD2 separately I am getting the correct sounds. When I am imputing through Sibelius, the sounds do not correlate with the staff assignments in VD2. I am using midiyoke as my virtual midi cable. I believe that my setup is correct. Does this sound like a familiar problem?
That did the trick! Now I really feel stupid. I was simply using one of Sibelius' standard templates, and not a TS one. Thanks everyone that assisted in this. I've learned alot along the way!
Maybe it's just like he's not using a templated .sib?
Hey Dave - I'm sure there's an explanation for this. I'm getting a little lost in your description however. I think it'll help if you can specify exactly what is happening. Here's what I'm unsure of in reading through your posts...

Are you saying that when you click certain staves to input notes in Sibelius, those staves aren't triggering the correct instruments in VDL2? Originally, I thought this is what you and Gabe were getting at.

Or rather, are you simply not hearing each 'sound' from certain instruments? If this is the case, let me know what actual instruments you have loaded (specify the EXACT name of the VDL2 instrument). If you are using the AutoRL instruments (which it sounds like you may be), you'll probably need to simply do a ";staff type change"; in the first measure of each AutoRL staff in Sibelius prior to writing. Staff type changes can easily be created by selecting a bar, then going to...
Create>Other>Staff Type Change>Percussion

....then choosing the appropriate VDL2 instrument you're using from that staff.

Let me know if any of this is in need of further explanation.
Jim - went through the steps and it all checks out. Still not working though. It my be my setup, or a bad midi yoke? The correct sounds play from 8vb middle C to Middle C. Middle C to 8va from middle C all sound D, 2 octaves below, or the ";snare shell"; sound on SnareLine Auto RL. Then once the notes reach G above that, or ";Decrescendo Medium Buzz";, everything is OK from there on up. Same deal with the tenor and bass voices. All of the keyboard stuff is working fine though. Does this seem whacko to anyone else?
For what it's worth, here's what I've found to be the easiest way to hear different channels from within Sibelius.

In the VDL2 midi setup window, be sure that all INPUT devices are set to OFF (including your keyboard) except for the virtual midi cable (IAC driver, Maple MIDI, MIDI Yoke, etc).

In Sibelius' DEVICES window, set the keyboard as your input. Set your VDL2 virtual midi cable (IAC driver, Maple MIDI, MIDI Yoke, etc) as the default output (it should be highlighted blue).

Important: Be sure the MIDI THRU checkbox is selected (still in the Sibelius Devices window). If it is, basically Sibelius will do the channel switching for you, so you really won't need to mess with changing channels on the keyboard. Just click the staff you want to hear, then tap on your midi keyboard and like magic, you'll hear that instrument. Click on a different staff, and voila...a different instrument! :)

Note - as Bill already mentioned, this is different than if I were just playing demos of the sounds between my keyboard and VDL2. In that case, I'd alter the midi settings in VDL2 so that its MIDI INPUT is coming from the keyboard rather than the virtual midi cable.

hope this helps.
Dave,

Try this on your Radium. In Sibelius, select your second staff, most likely tenors or channel 2. On your controller below the display should be a button titled ";Midi Select";, press the button. Along the top of your controller there are some keys assigned to specific commands, find the one that had ";midi channel"; associated with it, press it and then find the key associated with the number 2 press it and then press the key associated with the word ";enter."; After you hit enter press the ";midi select"; button again and test your sound.

If thisdoesn't solve it then it is above my head and some of the experts will have to try and resolve the problem. Hope this helps.

Gabe
So, I guess I'm back to my original question. I also use a radium midi controller.
Gabe,

The only time I have to worry about changing channels on my keyboard is when I'm using just the keyboard and VDL:2 to demonstrate. Otherwise, Sibelius takes care of it all for me.
Bill,

I still have to change my controller when inputting to Sibelius. I wonder if this is a glitch in my copy.

Gabe
The only time you need to change the channel on your keyboard is when you are using VDL:2 and your keyboard for demo purposes. If you are using Sibelius, VDL:2 and your keyboard, the sounds will change automatically when you go to the next staff. They will change to whatever channel in Sibelius and VDL:2 they are set to.
Dave,

You don't have to be running your sounds through your keyboard. Unless you change the channel on your keyboard as you change staves, you will get only one instrument through your VD:2 Kontakt player. I ran into the same issue as I was getting started with VD:2 and I use an M-Audio Radium which is on;ly a midi controller.

There should be some controls on your controller that allow you to change midi channels, check your keyboards documentation.

HTH,

Gabe
Im not running sounds through my keyboard, but through VD2 Kontakt. Maybe I missing it all together. When I have time, I need someone to talk me through it.
Dave,

You are not changing the midi channel on your keyboard. The playback should be fine you just get different sounds when inputting, right? Change the channel on your keyboard as well when switiching staves and you should be golden.

Gabe
Login or Signup to post a comment