ASIO4All driver question

I installed the ASIO4All driver to try to improve my playback from VD2 and i haven't had any success with it.

When I set my VD2 soundcard source to the ASIO driver, I get an error message indicating that a MME device was not found when I launch Sibelius after making the change. I only get that error when that device is selected as the driver in VD2. Is there something i need to change elsewhere to make it work correctly?

I've got 1 GB of RAM and I believe I have at least 1.7 Ghz processing speed but my playback is really choppy. I am using the windows default media soundcard also. The score I am currently working on has 11 channels being used via VD2 and Kontakt so I know I am asking alot of my system but will this ASIO4All driver help me?
I realized that once I got a chance to open up my VD2 player and look at the set up once again. I have all the setting right for it but i think I have some other file conflicts. After scanning through the ASIO4All forum, it looks like a lot of people have the same issue I'm having where the output is unavailable.

I haven't been able to read up completely on it yet but it looks like the only way to get around it is to disable the Microsoft GS Wavetable SW synth.
[quote=";gbass598";]

Does the ASIO show up as a midi output device? Maybe this is where I was having a problem. I'll have to double check my setup tonight since I never thought to look there. If it is there, I'm sure it is unchecked. I know every time I try to use the ASIO w/ VD2 I get silence and it shows the output as disabled even though I enabled it before launching the program. I'll look ino that and see if it fixes my problem.

Thanks,

Greg[/quote]

No. ASIO4all is not a MIDI device. It's more of a soundcard driver, which is very different.

Once you've installed ASIO4all, you should select ";ASIO"; as the ";interface"; in the SOUNDCARD setup. Remember, ";ASIO"; is an audio format like CoreAudio, MME, DX. Many different soundcards will offer the option to use an ASIO interface (for lower latency).

In the ";Output Device"; (still in the SOUNDCARD setup in VDL2), this is where you'll select ";ASIO4all...."; instead of your default soundcard.
[quote=";otaylor";] Now run VDL:2 and it should work - with asio set as your interface and output device. (But asio has to be enabled before you start VDL:2 or you will get no sound). If you get no sound the first time, close VDL:2 and open it up again. I hope this can help you.

I'm including the program link so it is on this topic page:
[url]http://www.asio4all.com/[/url]

Good luck

VDL:2 is awesome...thanks tapspace... :D[/quote]

Does the ASIO show up as a midi output device? Maybe this is where I was having a problem. I'll have to double check my setup tonight since I never thought to look there. If it is there, I'm sure it is unchecked. I know every time I try to use the ASIO w/ VD2 I get silence and it shows the output as disabled even though I enabled it before launching the program. I'll look ino that and see if it fixes my problem.

Thanks,

Greg
I'm pretty sure asio can help you. VDL:2 would crash everytime i started it up until i figured out my soundcard didn't support the four audio driver formats that work with VDL:2 and my computer would freak out. Asio can fix this for you, as long as you have a WDM soundcard. (Asio will let you know) Don't be confused: asio is not a replacement driver for your soundcard. Instead, it's more like ";liason"; between VDL:2 and your soundcard.

Make sure your soundcard driver (not VDL:2 soundcard option) is set to its original driver, then open the asio program. Click the advanced tab, make sure your device is highlighted in the top left, and click the ";enable/disable"; button a couple of times (just to the left of the advanced/simple button). Make sure it ends up on ";enabled";, then close asio. Why do you need to do this? Because that asio4all application only makes offline changes, so it doesn't affect your soundcard until you enable it. Now run VDL:2 and it should work - with asio set as your interface and output device. (But asio has to be enabled before you start VDL:2 or you will get no sound). If you get no sound the first time, close VDL:2 and open it up again. I hope this can help you.

I'm including the program link so it is on this topic page:
[url]http://www.asio4all.com/[/url]

Good luck

VDL:2 is awesome...thanks tapspace... :D
Gbass- I'm not sure if this is right or not, but Sibelius may be giving you that message due to its built-in Kontakt Player (gold/silver). Try this...

In Sibelius, in the WINDOW menu, select Kontakt Player to open it. Then click the AUDIO SETUP button. In the Audio Setup window, make the same settings here as you were doing in the VDL2 player.

I haven't actually used asio4all myself, so this is simply an educated guess. Perhaps someone who's used the driver with success can give a report on whether they've seen similar things.
Login or Signup to post a comment