VDL2/Kontakt 2 Wimping out, Suggestions?

Hey all--thanks for the continued support in all of this.

I finally got myself a copy of Kontakt 2, since I'm going to need banks and more than 8 channels, and got everything loaded and saved as a multi (hey that's pretty handy).

I assigned instruments to their own channels (12 instruments total) hit play in sibelius, going fine for a few measures and then when it hits an ensemble passage BOOM.  I just hear decaying whole note clicks.

I'm assuming there's some manner of configuration I'll need to set up to make this go away, but having never used Kontakt 2 or much experience with other rack software I'm not sure where to start.

[b]What I've Tried So Far:[/b]
-If an instrument can have a lite version, that's the one I'm using.  The memory footprint of all the instruments is a little shy of 400mb.  Not bad.
- Set the DFD setting maxed out (I suspect this isn't necessary since I have a lot of ram, but I may be wrong)
- All channels are on one IAC Driver port since I don't need >16 channels yet.

[b]My System:[/b]
1.67MHz Powerbook G4
100gig 5400 RPM Harddrive
2gig RAM
128mb Video Card
8x Superdrive

OSX Tiger 10.4.1
Sibelius 3.1.3
Kontakt 2

Where do I start?  I know it's a G4 lappy and that's not as good as a dual 2.7, but I would think that it should be able to handle 12 lite instruments (VDL2 handled 8 full instruments just fine in fact, and 4 of the 12 instruments in Kontakt 2 aren't even written yet).

Justin
I'm not familiar enough with the specs of an iMac to know, but typically external drives have a slower read speed.
Hey Guys!!!�� That worked GREAT!!�� Thanks for all your help.

Bill - You would suggest putting my samples back onto my internal hard drive on my iMac then?


thanks again
Scott,

You can still remove the individual reverb sends on each instrument in a bank by simply double-clicking the instrument (in the bank slot), which will then open the instrument as normal. Remove the reverb as described. Not a bad idea.

With 2GB of RAM, you can choose more RAM intensive instruments to load TOTALLY to RAM, rather than using DFD. I suggest you start with vibes, marimba, glock, and maybe battery instruments, and go from there. Anything that requires long releases, or fast action.

-Open the instrument
-Click the Group Editor
-Click ";edit all groups"; so it's bright red.
-in the ";source"; area, you'll see a pulldown menu that's most likely set to DFD. Change this to ";sampler."; This will prompt all samples to be reloaded to memory, and that'll do it.

Once you've done this with all your desired instruments, re-save the multi to avoid having to do this each time.


Regarding the DFD slider, you might find better results if you slide it farther to the right. I've found this is one you just want to tinker with till you find what settles well for you.

Good luck!
You have to go into each individual instrument and turn off the reverb.  It is on by default.

Also, an external hard drive will be slower than an internal hard drive typically even if they have the same rpm speed.  Reason being, data has to be transmitted over a USB or Firewire cable.
One quick question. 

I recently moved all my samples to a 160GB, 7200RPM, external hard drive from my computer I write on.  still haveing some dropping out in live playback in Sibelius.  Trying to get rid of Reverb...I use Instrument banks...

1.) I moved my DFD slider in Kontakt 2 all the way to the left which says ";12.ooMB";  that seem right?
2.) How do you get rid of reverb when you have all your instruments loaded into instrument banks?
FWIW, if you have 2g of ram, and you're loading 400mb of banks, turn DFD off.  Force it all into ram.

That's my 2c, your mileage may vary.
I said decay.  I meant release.
Thanks a lot everyone, the reverb and loading samples directly into memory did the trick.  Thanks Jim.

I haven't tried changing the note limit thing David; I'll try that when I get around to adding all of my instrument banks in since I'll probably need it.

Also Jim, for the life of me I could not find any ";little x"; in the reverb effect.  Through about 15 minutes of poking and cursing I found out that I needed to 1.) double click on the reverb send effect icon to expand the edit panel 2.) single click in the parameter dials until the entire parameter rack is highlighted 3.) hit the delete key on my keyboard.

Yay usability. :-)

But again, looks like I'm up and running.  Thanks again everyone.
I don't use Kontakt v2, I have 1.5.3.  But, check one other thing.  The amount of notes that are allowed to be played at one time by each instrument.  On 1.5.3 it is the box next to the midi number assignment box.  It has two beamed eighth notes, a number, a forward slash, and then another number.  Click and drag that last number upward to increase the number of notes that can sound at once.  I had to do this with keyboards especially because of their decay being longer than most.  While you play back a file, watch the number beside the eighth notes and see if it hits the number to the right of the slash.  If so, increase the value again.  I have also changed the decay of many of my keyboard instruments (shortened them) to be sure that I don't ";bottom out";.

- David
Justin - you may or may not already know this, so forgive me if I'm repeating old info for you...

Reverb in Kontakt is very CPU intensive. Since each instrument in VDL2 has the capability of adding reverb, this may be some of your problem within K2. In the VDL2 player, reverb for each instrument defaults to 0% (which is essentially ";bypassed"; altogether). However, when you load VDL2 instruments into Kontakt, the reverb remains active - in fact bypassing it still doesn't seem to improve CPU performance.

So your best bet is to remove the reverb from each instrument. Watch your CPU meter in K2 as you do this, and you should see it decrease significantly as you eliminate reverb from each instrument.

Here's how you'll delete reverb in each instrument...

[list]
[li]In Kontakt, click the little ";wrench"; icon to edit the instrument.[/li]
[li]Look down a few rows for the [b]'send effects'[/b] section. You'll see one square labeled ";reverb";. In this square, there's a tiny little ";x"; in the upper right-hand corner. Click it, to delete the reverb send for that instrument.[/li]
[li]Repeat for all instruments[/li]
[li]Re-save your multi.[/li]
[/list]

There are a few tweaks that will be built into a future enhanced K2 version of VDL2, but for now this process should help your playability quite a bit.

GBass also brings up a good point. Whenever possible, you'll get much better performance playing from RAM rather than DFD. Since you have 2 GB RAM, you may want to load more of the samples to RAM rather than DFD. To load an entire instrument to RAM, do the following...

[list]
[li]As before, click the 'wrench' to edit instrument[/li]
[li]Click the ";group editor"; button[/li]
[li]Click the ";edit all groups"; button so it's BRIGHT red.[/li]
[li]Just beneath that area, where it says ";source";, you'll likely see a pulldown menu that says ";DFD";. Change this so that it reads ";sampler";[/li]
[li]Kontakt will reload samples. Once it's done this, that whole instrument is now loaded to RAM and won't use DFD[/li]
[/list]

If you're going to experiment with this method, I'd recommend you start by doing it with battery instruments, Vibes, and Marimbas for starters, then see what your RAM allocation is for your multi. This should help performance as well.

Remember, anytime you're writing something with high levels of polyphony, CPU will be taxed. Loading samples totally to RAM will help a great deal, though still, CPU is called upon to play those samples in real time. You might try increasing your latency in the SOUNDCARD SETUP window of K2 as well to help a bit.

Hope this helps.
[/list]
That does make sense and I'll keep DFD on the low end of the spectrum, thanks.

I don't think that's quite the fix though, as I initially used DFD all the way on the other side (what you suggset) since that is the Kontakt 2 default, and I had similar performance problems.  In fact, all the way to left drops out almost immediately, and any variation of DFD from low to high produces the same dropping out as mentioned in my first post.
If your DFD is maxed out, that means you are not taking advantage of your RAM. You are trying to play all of the sounds from your hard drive. Considering your specs say you have a 5400 RPM hard drive, that won't work very well with lots of sounds. You've got 2 GB of RAM so switch yout DFD to the opposite end of the spectrum and allow everything (at least most of it) to be played from your RAM and it should work better.
Login or Signup to post a comment