Instrument playback problems

When I use my midi keyboard (M-Audio keystation 49e) the only sounds I get back are of the instrument that was first loaded into the VDL2/Kontakt player.  None of the other instruments loaded will play back their sounds only the sounds produced from the first loaded instrument.   It was working fine and I can't seem to make it work now.  Is there anything I might be missing or has anyone had a similar situation?
Are you talking about when you are just using the keyboard to hear the notes, or when you're entering the notes into your composition program?

Are any of the channels not set to a specific channel and are instead set on Omni?
Sounds like your [i]VDL2>Setup>MIDI-Input[/i] is set to receive input from the Keystation. If this is your intent, you need to switch channels on the keyboard itself (to trigger instruments that are assigned to different channels). Your keystation documentation should have information on how to change channels. It's pretty simple.

If however, you are triggering VDL2 from your notation environment, you should ensure that the [i]VDL2>Setup>MIDI-Input[/i] is set to [b]OFF for your USB Keystation[/b], and [b]ON for your virtual midi cable[/b] (maple, midi yoke, IAC driver, Midi Patchbay). Also ensure that ";midi thru"; is enabled in your notation program. When this is the case, your selected staff (in notation) will assign the sound heard from VDL2.
Got it to work.  Thanks.
Login or Signup to post a comment