Kontakt 2/Sibelius Playback

Hi Everyone,

I know this has been discussed already, but I really feel like I have a machine that should be able to handle my scores.  Maybe I'm wrong :).   I'm still getting HUGE dropouts during playback (as in, all sound ceases to be heard as soon as the polyphony increases).  Here's the info :

Dual 2ghz G5
1g RAM
Sibelius 3
Kontakt 2
Apple's MIDI Driver

I realize I'm a tad low on RAM, so I've messed with the DFD and latency settings as suggested in other posts.  Sometimes I can get it to come close to chugging through a thick section, but it never really works consistently.  Any suggestions on where to place these two settings?  Also the problem seems to be less intense if I start right on the dense chunk of music (as opposed to playing it from the start).  I've disabled scroll-through in Sibelius.  I'm using the ";lite"; versions of all sounds. 

I'm trying to playback:  2 vibe staves, 4 marimba staves, 1 xylo/bells, 2 synth, 1 guitar, 1 e. bass, 2 rack, 1 drumset, snare, tenor, bass, cym.  A heavy score, I know...any suggestions? 

That is [b]definitely[/b] pushing it for RAM- trying to get a full enseble + some additional electronic instruments on 1 GB of RAM is not realistic.  More RAM on a slower machine will always beat a faster CPU with less RAM when it comes to digital audio that uses a lot of samples. 

If you're trying to make a good recording, try grouping the music into smaller sections and combine them in something like Garage Band.  Separating the woods, metals, electrics, and battery will also let you fine tune the levels of each too.  While upgrading RAM will help, might not ever get perfectly smooth playback.  You will get better performance, and ultimately better quality of sound, if you use Logic, Cubase, etc. 

Remember that you are using notation software, not recording/mixing software.
Running Sibelius, Kontakt 2, and OSX is already consuming a good bit of RAM, so adding another 1GB can certainly lighten the load a bit. But as you point out, this is a pretty hefty load you're asking from a single computer. The ";all sound drops out"; situation is probably CPU overload (watch K2's CPU meter, and you'll know right away). Since you're using DFD, that will place more strain on CPU. Here are a few suggestions to help...

Vibes and Marimba are likely contributing to a large part of the polyphony hogging. If you have enough RAM available (you can check how much is used at the top of the Kontakt 2 window), you might consider loading these instruments FULLY to RAM (so DFD isn't called upon for those instruments). Open the instrument to edit in K2 (the little wrench icon), click the ";group editor"; button, then click ";edit all groups"; so it's bright red. In the ";source"; section, select ";sampler"; (instead of DFD). The instrument will re-load (loading may take a tad longer since all/full samples are being loaded to memory rather than just DFD buffer).

Once you've done this, check your memory usage (in K2). Keep in mind this is memory usage for K2 only...not everything else running on your system. So with 1GB RAM, you might not get a whole lot more than 600MB of K2 usage until you're about out. Adding more RAM will allow you to load more samples directly to memory (as described above) releasing some strain on your CPU.

Once you've made the sampler/DFD switch as described above, I recommend re-saving your multi so you don't have to keep doing it over each time you sit down to write.

If you find that you have these problems when sibelius is switching to a new page (scrolling playback), it may be because Sibelius is stealing CPU resources for the screen redraw. Try playing back from Sib with scrolling turned off and see if that helps.

Another thing you can tweak is the release tail on your marimbas. These are set fairly long by default for extra realism, however in fast/dense music, it's less necessary. Open your marimba, click the checkboxes ";hits 1";, and ";hits 2"; (so they are both checked), then scroll down to the ";modulation"; section (toward the bottom). Lower the RELEASE tail to about 1 second (1k ms). You'll notice once you release a note on this instrument, it may fade out more quickly than before (thus making polyphony more available for upcoming notes). Generally, this is probably ok since most of what you're writing may be more fast paced. It'll still decay naturally while you're holding the note.

Reducing release tails is a good idea as well for vibes, chimes, timpani. If doing so, i recommend you write exact rhythmic lengths in Sibelius (especially for longer parts...ie. tied whole note into a half note), so the note will get it's full natural sustained/decayed sound.

Another hint: Lower polyphony on instruments that don't need very much polyphony. In each instrument (in K2), under the name of the instrument, you'll see a polyphony reading like ";xx voices: 0, Max:32"; (or something to that effect). Instruments like (for example) ";egg shaker"; may only need about 8 voices of polyphony max, so click on the 32, and drag downward to allocate LESS polyphony to this instrument.

ok...that's a lot of info to digest for now. Let us know if you see any improvements. Good luck! :)
While we're at it, the point was made that Sibelius isn't the hottest thing for midi playback.  Of course, most of the time it's playing back donuts and eights in wind instruments, and not being technically challenged.  I think there are a few things to elaborate on from prior points.

Essentially your problems would be solved with something like Cubase.  Cubase 2 can probably be found on the cheap, and will help a lot.  For example, as a midi program, it's going to be efficient and accurate for playback.  Sib is worried about how the notes are engraved and are only now realizing the playback problems. 

Also, there's the FREEZE function - you can render out your audio in faster-than-real-time, and take instruments out of ram.

But let's not kid -- if you want to be editing in Sibelius and getting the playback, you're going to have to get some ram, or do some serious shaving out of your usage.

In K2, you can purge unused notes...

You can use GM or Soundfonts as a sub for the keyboards while editing to reduce ram usage...

Use the same channel for all 4 marimbas, etc...

Defrag your drive...

Turn off unnecessary startup programs...

Eliminate any reverb effects, including the setting in Sibelius!  Also make sure KSilver never loads if you don't need it.

And if you're just going to playback the midi to record or whatever, export the midi file.  Anything else will be more efficient than Sib3. 
Login or Signup to post a comment