Loading VD into Sibelius

Hi,

  Im having problems loading my soundfonts into Sibelius. I used finale before and i though ill try sibelius.
  I've loaded all the soundfonts in my manager but when i open up the mixer in sibelius and click on the sound drop down my sound fonts don't seem to appear? It seems to be set upo correctly in the devices but just seem to be having problems.

  The other thing i wanted to know is that can i export the midi on to cd so that it plays it with the VD fonts i have tried it before but just played as the normal custom sounds...piano etc.

  Thanks for any help Adam
Be sure you're using the VDL Sibelius template from tapspace and are entering your notes via a midi keyboard.
Adam,

I can't help you with the soundfont issue right now.  I haven't worked with that for awhile so answers don't come as easily as before. 

In regards to your recording issue, that is easy.  When you are exporting midi you are only exporting messages not sounds.  Your notation program sends the messages to your soundfont manager which takes those and lines them up with the appropriate VDL sound.  What you need is a seperate software program that will ";record what you hear.";  I think soundblaster card software comes with this already, I am not sure what it is called but it is included in the bundle of stuff you get when you purchase your card.  You can also go to www.aonesoft.com and download #1 sound recorder.  #1 will record what is coming through your computer speakers and will create an mp3 which you can then burn and distribute.

HTH,

Gabe
Technically, Sibelius does not ";load"; soundfonts. If your computer (or soundcard) is capable of loading soundfonts, then it may be possible for you to direct Sibelius to that as a playback device, but don't get confused. Sibelius does not actually host soundfonts. In the Mac version, you'll see a ";soundfont/dls"; column in the playback devices window, but this is merely to select a SYSTEM collection (found at: macintosh hd/library/audio/sounds/banks). In osx, you can place soundfont banks there (.sf2) and they'll be recognized by the operating system.

You left out some details that would help provide an answer to your question...
What kind of computer do you use? (specs, os, ram, etc)
What kind of soundcard are you using?
What version of Sibelius are you referring to?

If I'm understanding you correctly the ";sound"; dropdown menu, is most likely the one seen in the Sibelius mixer window. If so, this has nothing to do with soundfonts. This menu is there for selecting ";sound sets"; in Sibelius. You should find more info about them in your Sibelius documentation.
Hi Jim,

  I have Sibelius 3, VD, Finale 2005,

  I seemed to have my SF2 loaded in my Soundfont Bank Manager ok.

  I use: Windows XP PRO
            Processor: AMD Athlon(tm) 64 Processor 3500+,  MMX,  3DNow, ~2.2GHz
            1024MB RAM
            Description: SB Audigy 2 ZS Audio [A000]


Is that all you need?

 
That's excellent info Adam. Thank you for adding it. Check out my previous response about soundfonts. Since you're using Windows, Sibelius isn't going to actualy ";load"; your soundfont. Instead, you'll access it by setting the Audigy 2 (or whatever playback device is set in your soundfont bank manager program) in Sibelius as your default playback device. Be sure you know what 'device' is set as the output in your soundfont bank manager, and set your output device in Sibelius to the exact same thing. Then be sure you've made all these settings in the Sibelius mixer as well.

Keep in mind, once you're triggering these sounds, the ";sound"; pulldown menu in sib's mixer is only a convenient tool - it's not absolutely necessary to use it to assign sounds. You can bypass it by simply assigning each track to the correct device, channel, and bank (high). If you'd rather use the ";sound"; pulldown, you need to install the VDL1 Sibelius 3 soundsets which are available at (scroll down near the bottom of page):
https://www.tapspace.com/vdrumlinesupport.html
Cheers,

          I seem to be ok upto the Mixer part. All my my sounfont bank is fine with my devices in sibelius. They just don't seem to be working in the score. These are the settings i have but the mixer is just confusing me i can't get the right sounds. In the soundfont bank manager i have my drum sounds in bank (001) then the presets as (000) - snare, (001)-tenors, (002)-bass, (003)-field cymbals, (004)-pit cymbals, (009)-Glockenspiel, (011)-vibraphone, (012)-marimba, (013)-xylophone. but they don't seem to work within the mixer etc. Also if i import a score from finale as a midi will it play it with my fonts in sibelius?

  Thanks for any help. Im having a nightmare...hehe 
Adam - you need to be certain EXACTLY which [b]bank[/b], each sound is loaded into, and furthermore, you should make a note of which [b]program number[/b] is assigned to each instrument. You need to get this information from your soundfont bank manager. I know for a fact that VDL1 .sf2 cymbals are not typically assigned to program 004. The VDL1 helpfile contains information about soundfont program numbers assigned in VDL1.

When you're using soundfonts, banks are important. When you loaded the vdl soundfont, you loaded it into a BANK on your soundcard. Your GM soundfont should be loaded into its own bank, so you can access other instruments (like vibes, etc) from that. So if your GM bank is 001, be sure to enter that in for ";bank low"; in the sib mixer. Then if VDL1 is loaded into bank 002, be sure to enter ";2"; into ";bank low"; in your sib mixer.

You need to be sure you know all your bank/channel/program number settings before you expect to hear anything. Don't guess. All these settings originate in your soundfont bank manager. If that program is confusing you, i can't offer much help. I'd recommend you contact the documentation that came with it, or by contacting tech support of the manufacturer (creative labs?)
Thanks Jim,

  I have managed to work it out and set it all correctly. The only problem im having now is say on bass drums only 2 of the basses are sounding? When i try and input them only 2 play back and on play back. I can hear them fine in vienna and on my midi keyboard in my SoundFont Bank Manager? Thnaks for any help

Kind Regards
Adam
Login or Signup to post a comment