Opening Finale/VDL2 midi file with Digital Performer

For any Digital Performer users:

I'm having difficulty opening Finale 2006 midi files in DP. These are files using the VDL2 templates. VDL2 is loaded as a Native Instrument AU. When I attempt to open the file in DP I get a dialogue box saying the file didn't load and an error code of ID= -2. I can open other Finale midi files which used the other NI AU instruments, but the VDL files get me an error message and then the app (DP) crashes. The only thing I haven't tried yet is saving the file with VDL2 in stand alone and using MIDI inter-application (like it were a Fibale 2005 file). Any thoughts?

Finale 2006c
Digital Performer 4.12
Mac OS X.3.9
Hey Ted,

That's strange. I didn't think a .mid file would have any sort of reference to AU's you were hosting in the originating app (Finale 06). They'll contain midi channel information though, but still, that shouldn't have any relevance on which AU instruments you may have been hosting.

You may want to test it by simply un-checking ";use NI AU for Finale Playback";, then re-save the midi file, and try opening that in DP again. I wouldn't think this has any relevance, but you never know I suppose. If it DOES work, I'd start by re-activating the ";NI AU Playback thing"; in Finale again, then just re-trying the launch in DP. Maybe it was just something glitchy with the midi file.

I don't know DP, but is there a way you can select ";import"; rather than simply ";Open"; (or vice versa)?

I've tried saving the midi file with the AUs turned off and that produced the same result. As I said in my first post, this is only happening with Finale files using the VDL2 plugin. After my post, I even went ahead and tried it with VDL2 as a stand alone. At this point, the only thing that I haven't examined is how the notes were entered into the Finale file. Both of the files I'm having difficulty with were done using Corey's VDLMidi utilty for entering some of the snare and tenor notes. It's the only common point, so I'll probably reenter the notes into a fresh file and see what that creates.

Regarding importing midi files, DP only allows you to ";import"; audio. Midi files can be opened as though they were any other DP file. DP's history began as a sequencing app with notation and audio capabilties added. The only thing left is Digital Performer, all of the Mark of The Unicorn hardware and now Mach 5 and MOTU Symphonic Instruments (sampler/players like Kontakt).

I wonder if Finale is doing something screwy with the creation of the MIDI file. Maybe other Finale users have seen something on their forums. Since you got the same results when AUs were off (perhaps totally unloading them would be a better test case now that I think about it), I'm starting to wonder if DP might be the culprit. It might be worth trying to open the MIDI file in another applicaion (perhaps QTplayer or do you have GarageBand 2?) to see if it reacts strangely as well. You can open the MIDI file in TextEdit to view the syntax, though it probably wouldn't tell you much. But if there's some reference to VirtualDrumline or ";AU"; (which i don't think it would), perhaps deleting ONLY that would kickstart DP into reading it. A stretch perhaps, but it seems like there must be a logical reason for the error. Does your DP documentation offer definitions for error codes?
It was a Finale problem, sort of. The template did not specify a midi equivelant in the instrument list. The midi file would open in QT and playback using a piano but wouldn't open in GarageBand because there were no tracks listed. Any way, the issue has been resolved.

Login or Signup to post a comment