Midi Yoke not being picked up by Sibelius 4

Self explanitory.  I'm on a PC.  I'm using VDL:2 and Sibelius 4.  Everything is legitimantly purchased because i heard once before that using pirated things could mess up your options.  I'm pretty sure I've installed everything correctly.  The keyboard will play through the midi yoke and play the drumline sounds, however when I go into the Device Manager of Sibelius 4, Midi yoke is not listed under the devices. 

My other issue is that when i play the midi keyboard simply through the midi yoke, it plays a piano note as well as the drumline sound.  It's weird but im sure its something that will get fixed when I'm in the Sibelius program.

Help....

Jon Honeycutt
Jon,
You're probably getting that virtual memory problem because you've run out of RAM, and your hard drive is acting as a stand-in. For audio, that's a big no-no. The best solution would be to increase the amount of RAM in your machine. If you can pump it up to a couple gigs, that would be a great help.

You may be able to disable Virtual Memory in Windows. In fact, I'd recommend you go through all the tuning tips at:
http://www.musicxp.net/
You are absolutely right on that last one.  I downloaded the Midi OX not the Midi Yoke.  I'm a moron.  Now everything works fine.  Quick question though.  When it says I have low Virtual memory to run the different things, is there anyway to raise the virtual memory? other than buying something new?  I'm not THAT good with computers to know alot about what I would need.


THANKS JIM!



Jon Honeycutt
Jon,

Make sure you are using the most current version of Sibelius 4 (currently 4.1 - it's a free download from sibelius.com if you're currently using version 4). I remember there were a few issues with earlier versions not noticing certain virtual midi cables.

Just a couple settings to confirm:
[list]
[li]In VDL2>File>Setup>MIDI - turn all options OFF except under ";input interface"; turn Midi Yoke 1 to ON.[/li]
[li]In Sibelius>Play>Playback and Input Devices - under ";playback devices"; click on Midi Yoke 1 so its letters turn blue. This sets it as the default device.[/li]
[li]In Sibelius>Play>Playback and Input Devices - under ";input devices"; make sure ";Midi Thru"; is checked, and that your MIDI Keyboar (or midi interface) is highlighted in the list of MIDI devices on top (DON'T select Midi Yoke 1 here, that's bad)[/li]
[li]In Sibelius>Mixer - be sure each staff in your score is set to use ";Midi Yoke 1"; as the device. If it doesn't show up, click the ";reset sounds"; button (in the mixer window).[/li]
[/list]

If for some reason, you still aren't seeing Midi Yoke as an available device in Sibelius, I might suggest you try uninstalling it using ";add/remove software"; from your Windows Control Panel. Then re-install MIDI Yoke.

One other thing that may be worth mentioning. Midi Yoke is available at www.midiox.com. Their site is a little confusing to look at, and some users have made the mistake of accidentally downloading a program called ";Midi OX"; which is *not* what you want. Once you're on the ";Midi Yoke"; portion of their site, they give you a few options to download (which can also be confusing). The file you want to download is the one that says it supports Windows XP. At the current time, it's version 1.72. Here's a direct link to the download:
http://www.midiox.com/zip/MidiYokeSetup.msi

Perhaps you mistakenly installed the wrong thing earlier? Maybe not, just a thought.

Hope this helps.
I thought of the ";find new devices"; thing already.  It didn't make pick up even after I hit the button. 

Also, the Midi card is not set as the output device. Nor is the midi keyboard I have.

Thank you for trying though.  I greatly appreciate it.  Hopefully it will work soon. 

Jon Honeycutt
Hi Jon,

First problem- I think Sibelius has an auto-check feature that notifies you when you have new devices available to be used.  However, have you checked (Play > Plyback and Input Devices) to see if perhaps click ";Find new devices"; will make Midi Yoke show up in the list of options? 

Piano sounds- Are you getting piano sounds for all instruments when playing with the keyboard?  I'm not sure if this is pertinent or not, but check to make sure that you do not have your soundcard's MIDI device turned on as a output device.

I am not sure if these will help, but if not, but good luck... and welcome to the forum!
Login or Signup to post a comment