Lack of sound during playback in Sibelius after following available directions?

Ok, I'm relatively new to Sibelius (although I've got the hang of it like I want finally), I just bought VDL:2 and I'd like to think I an intelligent individual.  That of course was before these computer programs made an idiot out of me.  So here is my problem.....

I have followed the directions in VDL:2 to the letter (so I think), but I can't get any of the sounds to play back.  I can get VDL to make the sounds but not when I play them back in Sibelius.  I have downloaded and installed the MIDI Yoke program/ patch thing and it appears in Sibelius and VDL.  I downloaded the ASIO4ALL program and that screwed up my computer completely, so I deleted it and now my normal sound works again.  I don't have a MIDI keyboard and at the moment can't afford to purchase one.  I'm at a complete loss as to what I don't have the correct settings for.

What am I doing wrong?  Am I just another case of an idiot with a computer trying to act intelligent?  Any help in this area would be greatly appreciated.  My self esteem is rapidly diminishing as I type.  LOL
Don't ask me why, but this time I was able to get that to work (it hasn't always in the past).  When I went back to try and play it in Sibelius it locked up and wouldn't play, as well as effectively stopping Sibelius from working. 

Do I have another problem possibly now? 
Well, if that worked, you narrow down the possibilities quite a bit...  if that test worked, you have put midi events through the midi yoke pipe from Sib to VDL2.  While it might not solve your problem yet, it demonstrates that essentially the settings are working.  So you're not crazy, and you are following the instructions.  It takes much of the uncertainty out.

As for Sibelius, a few things...  can you confirm that you are using 4.1?

Second, can you do something else?  Try a brand new score without the template.  Just a piano staff.  Put some notes in, and route that through to the same marimba setup.  If it doesn't initially work, set the VDL channel to omni and try again.  Then check the mixer -- make sure it's out via the MIDIYoke connection.

If you can get a sheet to play some marimba notes, we're on our way...  let us know.
If Sibelius locked up when you were entering notes, you probably have a midi loop. This happens when your INPUT device, and OUTPUT device are set to the same item (in the ";playback and input devices"; window). If you have Midi Yoke 1 set to ";use";, be sure it is *not* set as your input device. If you were using a MIDI keyboard, that's what you'd select for the input device. Since you're not, just set the input device as something other than Midi Yoke 1.
I do have Sibelius 4.1.  I loaded the update 2 weeks ago.  I could get the sounds to work in both VDL and the Playback Devices window in Sibelius, but still no sound when I play back a score.  I tried a new score and everything to no avail.  My settings are correct, per Jim's advice.

Next....??  And the saga continues. :)
You are a patient man Neil. Thanks for hanging in there. Not to have you duplicate too much effort, but I think it would be helpful if you could list all your settings in:

-VDL2 MIDI Setup
-VDL2 Soundcard Setup (and if you have other options in ";interface";, please list those as well)
-Sibelius Playback and Input Devices
-Sibelius Mixer (choose a staff and list settings for device and channel)

I'm a little worried about your processor. Per the VDL2 system requirements, it is not supported on Celeron processors although I have heard people have successfully played back small scores on one. Usually at least a Pentium 4 or Athlon would be ideal. The Sigmatel soundcard also sounds a little questionable, however I don't have much knowledge on the ins and outs of those.
SigmaTel is the onboard for Dell laptops...
How about doing that marimba test, but using the windows midi module?  Does that work?
Any more news?
VDL:2 MIDI Setup:

Input Interface - MIDI Yoke NT #1 - On
                        - MIDI Yoke NT #2 - 8 - Off
Output Interface - MIDI Yoke NT #1 - 8 - Off
                          - Microsoft GS Wavetable SW Synth - Off

VDL:2 Soundcard Setup: (Other Options)

Interface:          Direct Sound (MultiMedia)
Sample Rate:    44100 (22050, 32000, 48000, 88200, 96000)
Ouput Device:    DS SigmaTel Audio
Output Latency: 40ms

Sibelius Playback and Input Devices:

Playback:  Device - Use - Sound Set - Latency

Kontackt Player - No - Kontact Silver - 40
MIDI Yoke NT:1 - Yes - General MIDI - 40
MIDI Yoke NT:2-8 - No - General MIDI - 0
Microsoft GS Wavetable SW Synth - No - General MIDI - 0

Input Devices:

MIDI Yoke NT: 1
MIDI Yoke NT: 2 ( highlighted)
MIDI Yoke NT: 3 - 8

MIDI Thru: Checked

Sibelius Mixer:

Snare Drum
Device: MIDI Yoke NT: 1
Sound: Standard Set
Bank High & Low: Off
Program: 0
Volume: 127
Pan: 0
Channel: 10
Distance: 150

Hopefully that will help figure things out.  I too have my concerns about my processor and sound card.  I've been looking into buying a new desktop computer, but I don't know how to afford it yet.  I'm hoping for a while I don't have to. 

Forward...march....and step!
Neil,

Thank you for all the thorough details. By supplying those, you've helped us to not have to ask the usual round of twenty questions.

Here's what I believe is the main culprit. You must ensure the [b]channel[/b] in the Sibelius mixer (for each instrument) corresponds to the channel that that instrument is set to in the VDL2 MIDI-IN field. All your other settings look correct. Sibelius and Finale often default percussion staves to channel 10 (for the general midi folks), but since you're not using GM, you can set the channel to anything from 1-16 as if it were any other pitched instrument.

Since you listed the settings for your Snare Drum staff, let's focus on that one for now. Go to VDL2, and check what channel your snareline is receiving midi-in from (see page 26 of the VDL2 manual if you don't know what I'm referring to). If it's set to (for instance) Channel 1, then go back into the Sibelius Mixer, select your snare track, and set the ";channel"; field to ";1."; Repeat this process for each instrument, then save your score so you don't have to do this over again. That should do it.

One other bit of advice. It might help performance a bit if you set the Latency for Midi Yoke 1 in the ";Playback and Input Devices"; (in Sibelius) to 0 (zero). When we talk about adjusting latency, it usually pertains to the latency setting within VDL2's Soundcard setup window. The way you have it set up, there's 40ms latency in Sibelius, then another 40ms from VDL2, resulting in a total of 80ms, which will likely be way too high.

Let us know if this yields any results for you. Good luck!
Well I finally have a clue!  I got all of my setting in the proper order and everything works!  I even borrowed a cheap MIDI keyboard from the school I work with.  Now that I have all the sounds working I've started to figure out how to do some of the notation entering via the keyboard. 

Thank you everyone for your help.  All of your suggestions have helped me to better understand VDL and to get my settings and everything correct.  I appreciate it.

Now I have to go read more of the forum to figure out the easiest way to enter notes with all of the ornamentations and such as well as figure out why I'm still getting crummy playback.  I suspect it's my slow processor this time. 

And the saga continues.... :)
Neil,

Two quick fixes for the playback. . . In the VDL2 app. preferences increase the latency. Also, the two music notes to the right of the MIDI channel, lower those for the instruments.

Hope this makes sense.
Login or Signup to post a comment