sibelius is telling me a midi input device can't be used.

i opened sibelius today and i got a box that read ";A midi input device can't be used. then it tells me playback devices have been changed, and i should check to see my playback devices, so it directs me to that box. it states that i am using the same playback device and nothing has changed, so i click the input device button, and then a box comes up saying ";The midi subsystem returned an error. Perhaps another midi application is running. the error is: error 2 a device id has been used that is ut of range of your system."; i am not using any other midi debice or anything out of the ordinary. It sounds to me like some one has hacked my serial number and is using it or somthing.
The same thing (sorta) happened to me.  After a phone call to customer service tech support - here is what worked to fix the problem.  Open the ";Playback devices"; and double click on the ";default"; button.  Quit Sibelius and then restart Sibelius.  It fixed my problem.  It let mw know if it works for you.  If it doesn't, I might have another idea...
I have the same error message when I open Sibelius 4 but I can't seem to find where this ";default"; button inside the ";playback devices"; menu.

Also I noticed after toying with it a bit more that if my midi keyboard works with Virtual Drumline meaning it will actually let me preview the sounds the error message occurs.  If I open sibelius without first open VD then it works fine but will only play like piano notes in the template, once VD is opened it shows the error.  I am assuming that Sibelius thinks I am running multiple midi applications or something along those lines, I am no computer guru by any means.

Thanks for the help
The ";default"; button is in the ";playback devices"; menu on the right.  You can only click on it and then you have to shut down Sibelius and restart the program.  I am not sure of the recent update (just released within the last week) fixed this bug or not.
I have this exact same problem only my error message is ";error 4"; instead of 2. It says there is already another midi app in running, and to wait until it is available. this proble came out of nowhere...Thanks for any help. ohhh and I couldn't find the ";default"; button either.

The ";default"; button I am talking about is not really a button.  Open Sibelius.  Under the play menu, go to Playback and Input Devices.  In the dialog box that opens up, make sure that ";Playback Devices"; is selected at the top first.  Next, look in the part of the window that lists all your devices, (Knotakt Player, Apple IAC Driver (as I am using a Mac), etc.).  There should be 4 columns across the top of this window - Device, Sound Set, Latency (ms) & sound font or DLS.  In the Sound font column, I see the word ";Default";.  The Sibelius tech told me to double click the word ";Default";.  After you do this, quit and restart Sibelius.  this solved the problem for me when it happened a while back.

I don't know if this helps your particular situation or not but it fixed whatever was going on with my set-up here.

Hope this helps!!
OK, I must be retarded...LOL but I really appericeate your help. I am going to the ";play"; menu. Then going into ";Playback and Input Devices"; and the ";playback Devices"; comes up as the first window of two (The other being Input devices) My options are as follows; Device, Test, Use, Sound Set, Latency. Under all of those there is not anything that says ";default";, so I haven't been able to try that. What has been happening is that I'll open a ";work-in-progress"; VDL2 score or one that is already done and worked fine for a long time. Then I'll open VDL2 and load Snare lite, Tenor lite, and Bass lite in channels 1,2,and 3. And that has worked beautifully until one week ago. (Two weeks after I bought a new M-Audio O2 midi keyboard). The O2 worked fine until one week ago. I opened a score and the box that says ";A midi input device can't be used...."; as jamesriverdrums had explained. SO I go and try to look at my ";input Devices"; and another error comes up. Mine just happens to be error 4 instead of 2. but they say the same thing. It tells me that the Midi device requested is being used in another application and to wait until its available.

When I hit the keys on my Midi keyboard I hear the sounds straight from VDL2 and I can see the keys on the player moving with my keystrokes. However nothing plays back when I hit the play button on sib. 4. other occurances are that I can get VDL2 playback on sib.4 without the abaility to input from midi. Or I can input w/ midi but it plays panio sounds instead, during that I cannot see or here any VDL2 sounds unless I click on the onscreen keyboard with my mouse. I am officially stumped.

VDL is set to input w/ USB audio device (Everything else off) and output w/ MIDI yoke 1 (everything else off).

I am running windows XP Professional with one gig of ram, VDL2, Sib. 4, M-Audio O2 keyboard.

My drum set skills have improved qutie a bit since I've been forced off my computer and onto my kit. so alls not bad, but I have some shows to write and this is killing me...You guys all rock!


It sounds like your VDL midi settings are slightly off. VDL should not be sending midi data [i]out[/i] at all, which is probably why Sibelius isn't able to use MIDI Yoke as its output (because you have VDL using it...which is incorrect. MIDI Yoke should be the [i]IN[/i]put into VDL).  Try this:

In VDL MIDI Setup>[b]Input[/b] Interface:
Set Midi Yoke 1 to ON, and all others off

In VDL MIDI Setup>[b]Output[/b] Interface:
Set all items to ";off";

Once you've done this, restart Sibelius, and open one of those scores you're talking about and see if the error goes away.
Login or Signup to post a comment