Updating to VDL:2 Version 1.5 Major Snag

The instructions are extremely clear: drag and drop 2 folders thereby replacing the old ones.  My computer doesn't like that idea.  The Multis folder went over without a problem.  When I moved the Instruments folder an Error popped up reading ";Error Copying File or Folder: The system cannot find the file specified.";  I tried moving files individually that were in the folder but the files that won't transfer are the ones with the same name as folder.  Windows keeps asking me to change the file name and I have no idea what that will do to running the program smoothly.  I've hit a major snag and all I can do now is reinstall VDL:2 and get back to work until the update can work the way it's supposed to.  Any help would be appreciated.
A couple things to clarify first:

- Make sure VDL:2 is closed when you are updating.�� If the program is open, you will not be able to overwrite the 2 specified folders.

- Right click on both sets of 'Instruments' and 'Multis' folder (both in 'Virtual Drumline 2 Library' folder and in 'VDL2 Lib 1.5 update' folder), and make sure the 'Read Only' check box is clear.�� If there is a faded color in the box instead of a check mark, that means that some, but not all files in that folder are read only.�� If that is the case, click the check box twice.�� The first time it will put a check mark in the box, the second time it should clear it, and the check box will be empty.

By the error message you are posting, it sounds like there is either a corrupt file in either your update, or in your current VDL:2 Library, or one of the folders you were updating was moved in the midst of your update.

To make sure there are no corrupt/incomplete files:

1)�� Reinstall VDL:2, and make sure it works like it did before you tried to update.�� The reason you should do this is because since you tried to update, you make have copied over some library files, but not all.�� Reinstallation will make sure your library is complete before and after you install the update.
2)�� Download the 1.5 update again *but in a different place on your hard drive*.�� Sometimes a download will result in the file being corrupt.�� This is caused by windows switching around or misplacing a ";packet"; of information in the download, or an error (unreadable) section on your hard drive.
3)�� Extract (unzip) the files from the .zip update file.�� PLEASE NOTE:�� Devote your computer's resources to this update.�� - If you have other programs running while your unzip, this could result in a corrupt or incomplete file (like in step 2).

Now there should be a folder next to your .zip folder named 'VDL2 Lib 1.5 Update'.�� To make sure your extraction was successful, right click on the folder and then click 'Properties'.�� You should see in the first section, 5th line down ";Contains: 643 files, 70 folders";

Now you should be able to update by following the instructions included in the 1.5 update 'Read Me' .pdf file

Important tips for updating:
- If you would like to, copy one folder at a time (Multis, then Instruments), or even copy the subfolders in the updated 'Instruments', and paste them in the VDL:2 Library 'Instruments' folder.
- Again, don't have any other programs running while windows is copying over the folders.�� This is the most important step of the update, and you don't want any error messages.
- DO NOT move, or delete the update folder during the process of copying the update into your library.�� This will result in an error message, and and incomplete library for VDL:2, and you'll probably have to start this whole process over again.

Sorry so lengthy,
Hope this helps - keep us posted. (bah doomp ching)

- OT
Some great and insightful technical advice Owen. Good stuff!

One other thing to try might be this. Remove the old ";Instruments"; folder first (place it in the trash, or somewhere else), then replace it with the new ";Instruments"; folder. That way your computer won't worry about replacing the folder, but instead just moves it there.

It may be a dumb question, but did you unzip the update before dragging folders? Trying to drag the folder out of the zip file prior to unarchiving the .zip file may introduce some glitches. Not too sure.

As Owen already said, keep us posted!
Login or Signup to post a comment