Can't Find Files

I just installed my copy of VDL:2 on my laptop. When I tried to load ANY instrument, it said it couldn't find them. Let's say I wanted to load the ";general midi"; drumset. This is the error that would come up: [b]could not find sample: C:\Program Files\Tapspace\Virtual Drumline 2\Virtual Drumline 2 Library\<Virtual_Drumline2_part2.nks>\Drumset Samples\DS_FlTom_01.wav[/b]


I reinstalled VDL but it still does the same thing. What's wrong?
Are you on a Windows or Mac machine?  Did you upload the samples to a different hard drive or folder then the default?  I know when I install some programs on Mac I have to make sure to select ";custom install";  instead of ";easy install"; in order for everything to be installed from the disc.

Gabe
I'm on a Windows. I haven't custom installed anything, although I could try to manually select the destination for all of the files.
Look here:

C:\Program Files\Tapspace\VirtualDrumline 2\Virtual Drumline 2 Library

In there, you should see two folders. One is called ";instruments";, the other is called ";multis";. If this is the case (which it sounds like it is), that's good. There should also be three large container files in there named:
Virtual_Drumline2_part1.nks
Virtual_Drumline2_part2.nks
Virtual_Drumline2_part3.nks

If you do not see these three files in this folder, somehow they must have been moved or installed incorrectly. Fear not though. All you need to do is find them (do a file search in Windows), and move them into that folder.

Once you've done this, restart VDL2 and try loading an instrument again. All should work at that point.

By default, those files should all be in the same folder, so I'm not sure why they aren't now. Nevertheless, once you've corrected this, simply don't move the library folder (or any of it's contents), and everything should work fine from there on out.
This has been a catastrophe. I tried manually selecting a destination, and the setup installed the files. But this time, when I clicked ";general midi set"; to load, it didn't load them at all! So I tried putting all of the folders into ONE folder, and then when I started the program, it said something along the lines of ";could not find output source"; or something like that. So I had to manually select where the folders WERE. When I did that, I tried again to load the ";general midi set"; and I got the same problem as before. So I clicked the uninstall file, but it didn't work since for some reason I moved the files around. So I manually deleted all of the files and folders, but little did I know this doesn't delete them ENTIRELY. I went into control panel to use ";add or remove programs";, and when I tried to uninstall it said the uninstall file was missing. So I tried re-installing again, but this still didn't work because the other ";instance"; of the old install was still on the computer, giving me the same error that it can't find the files. I don't know what else to do, now.


Oh, and about the .nks files: Yes, they all were in the same folder, which is why I can't figure out why this isn't working...
Yikes. Hang in there. Once this is resolved, I'd recommend you be very cautious before moving any VDL component files around. Sample containers and their accompanying instrument files are very particular about their relational locations, so you can't treat these like any old file that can go any old place unless you're very clear on how they are affected by relocating them. Most often, these files are installed exactly where they should be, and as long as the user doesn't move things around, it works fine and isn't a problem.

So assuming your installation is still OK, open VDL2, and click the ";options"; button on the face of the player. This brings up the ";settings"; window. In this window, just under the ";lock memory"; button, you'll se a button that has a very long field to the right of it - this is the ";library path"; button. Click it, and you'll see a dialog window appear where you should navigate to the ";Virtual Drumline Library"; folder. When doing this, be sure to select ";Virtual Drumline 2 Library";, and do not select any of the contents within the folder. With this path set, now VDL2 will know where to find your library files. The only other thing you need to be certain of is that the three large containers are in that folder, as well as the ";instruments"; and ";multis"; folders.

If your installation has somehow been sacrificed by all the tinkering, it would probably be wisest to fully uninstall the library completely, then re-install. If the ";add or remove programs"; control panel isn't working properly now, we'll have to walk you through a manual uninstall as you need to be sure to remove any component files that aren't immediately obvious.
Login or Signup to post a comment