problems with vdl2 on intel mac

i just got a macbook pro and had a problem vdl2. I got through the installation just fine, but when i tried to open vdl up , it said.....( Warning: could not open file! It should be located at [ not set]: Virtual_Drumline2_part1.nks.....Would you like to select a different directory now? ) I followed the instructions in the manual and am not sure what I am doing wrong.  Anyone got any ideas.....I also searched the forums and didnt come up with anything....thanks for the help y'all.

macbook pro ( intel core 2 duo) 2.16GHz
1GB ram
vdl2/sibelius 4
digital performer

-Darryl Jones

Its working now....I deleted the com.native-instruments.Virtual Drumline 2.plist and Virtual Drumline 2.plist and reinstalled vdl2. After that, it worked just fine...
Thanks for all the help guys...

-Darryl Jones
[quote author=djones link=topic=1441.msg6615#msg6615 date=1164618656]
the installation error message was actually a ";application installation error";

It sounds like you should completely uninstall and reinstall the software. Not sure why this happened, but this would be the safe course of action

To do this:
1) Delete the entire ";Tapspace"; folder. You'll find this in your main ";Applications"; folder.

2) Find the following two files (in your Library>Preferences folder) and also delete them.
[li]com.native-instruments.Virtual Drumline 2.plist[/li]
[li]Virtual Drumline 2.plist[/li]

3) Do a search for ";virtual drumline"; and delete any other files that look like they have anything to do with the VDL2 installation. Also do a search for ";virtualdrumline"; and do the same. This may turn up some .component or .vst files depending on how you initially installed it.

Once all the above items are in the trash, empty it. Then re-install the software. It might help to do a ";custom install"; when you run the installer. You'll see a screenshot of this on page 7 of the VDL2 manual. To play it safe, check all the items under custom install to be installed (basic installation, VST, RTAS, Audio Unit, Library).

Once installed, when you launch VDL2, if you get the message ";could not open file. it should be located at, etc";, then follow my suggested steps in the earlier post.
I just got my MBP last week and I had the same problem. Here is the way I made it work. The first time it asks you to set the new directory hit ";No";. It crashed everytime I tried to set it at this point.
Now VDL2 should open up. Go to Options under the ";LOAD"; menu. The fourth button down on the left side has the old directory. Click on it to set the new path.

I also re-installed with multiple options and this was the way it worked for me. I hope it helps.


the installation error message was actually a ";application installation error";
      I tried what you told me, but after I did it I got a message to reinstall vdl2 due to an error.  Here is what I tried....

      1st-I just did an easy installation, and got the vdl2 library message and the installation error message.
      2nd- I did a custom install where I checked off everything but the rtas. I still got the same result.
      3rd-I did a custom install but only checked off the vdl library and got the same result.

    Could I be getting the same result because im not un-installing it all the way before I reinstall it? I made sure to put the tapspace
folder in the trash and empty the trash, so im not sure what to do.  Anyways, thanks for the help and hopefully we can figure out the problem.

-Darryl Jones

Fear not. The error message you're getting looks more intimidating than it is. Basically, your library location hasn't been set. Not sure why, but it's easy to fix.

Open VDL2 so you get that message again. When it asks, ";Would you like to select a different directory?"; select YES. In the resulting dialog box, navigate to:

Macintosh HD>Applications>Tapspace>Virtual Drumline 2>Virtual Drumline 2 Library

Highlight the folder: ";Virtual Drumline 2 Library"; (don't select anything in the folder). With this folder highlighted, click ";choose";.

Once you've done this, you should be all set. If for some reason you don't see the ";Virtual Drumline 2 Library"; folder, let us know. It's possible that you didn't install the actual library files if you deselected that part during the installation process.

Login or Signup to post a comment