yet more playback questions.

VDL Gurus;

(Dell XPS 3 GHz, 3 Gig Ram
SoundBlaster Audigy 2Z
Sibelius 4, Kontakt 2)

I'm beginning to work on a new score using about 9 instruments.  I'm noticing that the natural resonance of both timpani and marimba notes is being ";chopped"; as soon as the next note is articulated.  Example: marimba plays eighth note Bb-F dyads repeatedly at Q=160.  The decay of the 1st double stop is chopped as if to make room for the next double stop, which makes for very clunky playback.  Another way of saying this is that the notes ring only as long as their value, so if the notes naturally ring longer than the rhythm, the decay is stopped. All this happens very quickly (since the tempo is quick), which as I said makes for rather unrealistic playback. 

The same issue arises on xylophone, and is mostly noticeable in the low octave, where resonance is more pronounced.  When playing fast scale passages in that register, the notes' decay is chopped as soon as the next note appears, i.e., the next 16th note in most cases.

Advice?

Thanks!!
Exactly. Remember, that polyphony is being used the entire time a note is ringing, so it's best to keep vibes and marimbas (for example) above 32. Typically, the default settings will work pretty well, so don't necessarily feel like you have to do a lot of editing to the instruments themselves. Performance improvements can often be more easily accomplished with the DFD settings, and the soundcard settings like latency.

Hang in there! Sounds like you're making good progress. :)
That should be ok at 180k as long as your RAM isn't too full...

In this case, ";voices"; are the number of sounds at any given time.  What happens is Kontakt restricts how many samples that rack can have playing at any point.  Thus, if you play notes like low pit notes that resonate for a while naturally, you'll hear them cut off.  In your example, if you have a marimba at 2 voices, when you play note #1, and note #2, once note #3 comes along on the list, Kontakt shuts off note #1, since you can have only 2 ";active"; voices.  Often in real world situations, you get a loss of resonance, and a ";pinched"; sound, since it's mechanically making something unnaturally staccato.

You're farther on the learning curve than you realize.  If you're playing with this stuff, you're there.  Best of luck Shawn.
Jim/Drumcat,

In each of the instrument ";edit menus"; I had, about a week ago,  taken the ";Max"; voices on every one of my instruments down to like 2 or 4, since I thought this would be appropriate since each instrument could play on 2 or 4 notes at a time (4 for vibes and marimba particularly).  I didn't realize that it would have such an adverse response during playback.  Could someone briefly explain why that was?

Anyway, this seems to have fixed it.  I also over-rode the 60k preload amount to about 180 (I can go as high as about 400).  Is that ok?

Thanks for both of your help!  This Kontakt 2 has quite a loooooooong learning curve.

Shawn
Thanks for the extra info drumcat. Hopefully you can help troubleshoot this as I'm not much of an expert on those Soundblaster cards.
Actually, this is apparently standard fare.  A lot of opticals just run 48/96/192.  48 vs 44.1 shouldn't be too big of a CPU hit.

Mark me down for this one -- he's got enough ensemble instrument voices, but the individual instruments don't have a high enough number of voices.

Shawn, under voices > max in the main instrument rack, see if raising those maximums help.  Also, you may want to slightly override the 60k preload amount for each instrument.  Try that second.
Hmm, you may have stumped me on this one. I would guess that there must be some other piece of configuration software with your Soundblaster that would allow you the ability to control such settings. I'd be surprised if 48K was the lowest sample rate you were capable of. If you are certain that all the included software was installed with that audio card, my best advice would be to check with your Audigy docmentation, or check with the folks at Creative Labs on how to lower the sample rate. Have you checked in the ";sound and audio devices"; control panel?
........additionally,

I've come across a window  (the ";Audio Console";) within the SB software.  There are a series of tabs, one of which is SPDIF I/O.  Under ";Digital Output (PCM) Sampling Rate Settings";, it offers me two choices: 48 KHz and 96 KHz.  The one currently chosen is 48 KHz.  I was wondering if perhaps this is where K2 got its ";default"; 48000 for the sample rate.    Again,  within the Creative software I don't appear to be able to change it.  But I am certain you may know of a way to alter this...thanks again for helping me with this.

Shawn
Jim,

Somehow, I am unable to change the sample rate within K2.  Yes, there's a drop down menu attached to it, but the only choice is ";48000,"; and I also cannot double click the value to enter any other value.

I tried going through the software that came with my SB card, but I'm unable to find anything that will allow me to adjust this figure.  Any thoughts?

Shawn
[quote author=Shawn Hart link=topic=1466.msg6741#msg6741 date=1166399449]
Jim,

1. The settings in File>Setup>soundcard are:  Interface : ASIO
  Sample Rate    48000
Output Device  SB Audigy 2 ZS ASIO [DCCO]
Output Latency  20 ms    (I remember adjusting this)

2. for DFD:  Amount of memory reserved for DFD streaming voices: 360 MB
  Maximum # of stero DFD voices you'll be able to play: 384

** I think I chose ";sampler"; as opposed to DFD  in the ";source"; drop down menu under every instrument**

anyway, #3
I do notice that frequently, the CPU meter runs between 3 and 5 vertical bars in the K2 window; moderately below half I guess.

Anyway, I hope this helps.  Thanks for your help!

Shawn
[/quote]

This helps a lot. Thanks for going to the effort of digging up those settings. It helps to get a clearer picture of how you're setup.

Your sample rate is set too high in the K2 soundcard setup. You should set it to 44100 which should be default for CD-quality audio. Going higher than that can definitely affect CPU performance.

You may also want to adjust your latency to around 30-40ms. May take some moderate fiddling to see what gives best performance.

Try dragging the DFD slider so it's a little more towards the right (say around 75% to the right?). May take some trial and error to see what gives best performance.

Let me know if these suggestions help. I think the sample rate is the main culprit.
Jim,

1. The settings in File>Setup>soundcard are:  Interface : ASIO
  Sample Rate    48000
Output Device  SB Audigy 2 ZS ASIO [DCCO]
Output Latency  20 ms    (I remember adjusting this)

2. for DFD:  Amount of memory reserved for DFD streaming voices: 360 MB
  Maximum # of stero DFD voices you'll be able to play: 384

** I think I chose ";sampler"; as opposed to DFD  in the ";source"; drop down menu under every instrument**

anyway, #3
I do notice that frequently, the CPU meter runs between 3 and 5 vertical bars in the K2 window; moderately below half I guess.

Anyway, I hope this helps.  Thanks for your help!

Shawn
There are a couple things that might help this situation, though I can't say for sure exactly what might be happening without a little more info on your settings.

1 - In K2, what are all the settings currently under File>Setup>Soundcard?
2 - In K2, what are the settings currently for DFD?

3 - During playback, when you hear these undesireable results, watch the CPU meter and the DFD meter (at the top of the K2 window). Is the DFD meter getting pretty high?

Login or Signup to post a comment