Frustrating Hiccups on playback

Ok.  I have read almost every post regarding this, making sure I have the correct settings, etc...

I have a:
MacBook Pro 17";
2.17 GHz Core Duo
2 GB RAM
Sibelius 4
I am getting horrible hiccups, tempo fluctuations, problems with marimba roll playback.  Polyphany seems to be the culprit...but I shouldn't have any problems, should I?
I have tried using light instruments, changed the delay settings...but it STILL maxes out my processor (according to VDL2).  Help!
Well if you're not using DFD, and everything is in ram, there's almost no explanation for this...  unless you go back to Sibelius.

Have you optimized Sibelius for playback?  Make sure there's no page movement during playback.  Close any other applications that don't need to be open.  Turn OFF the reverb in Sibelius.  Then observe if your CPU is maxed out should the problem continue.

Often times, Sibelius will draw from your resources to redraw as it moves around, following the playback, to the point that this can happen.

Let's assume that doesn't clear it up.  After that, I think it would be good to listen to a clip of audio.  Can you post it?  If not, send it to me at mat@cityofrain.com and I'll post it publicly.
Surely.  I am NOT using DFD.  I also forgot to mention that I have the 7200 RPM drive option.

I have set my latency to various settings.  Currently, I am at 45 ms.  I have had it as high as 200 ms with no luck.  I have gone into options and flicked every possible combinations of options.  Currently I dont have 'autoconvert loaded samples to 32 bit' selected, although I have to test it. 'Lock memory' is off.  Sample rate is 44100. 

I never installed the DFD plug in, so...unless its auto-on, I don't have it on.

Any other info you would like?  I would be happy to provide.
Driver buffer?  I bet if it's most commonly on chords, the DFD settings are in need of adjustment.

ScadesTimp, can you fill us in a little more on your settings within VDL2?
I've tried writing out the desired rhythm to not much success, I think it may be a polyphony problem, but I could be wrong.  They are 3-4 note rolls.  The hiccupping also happens when vibes play a note and sustain, not roll.  It hiccups on chord attacks.
My guess is that your marimba tremolos (slashes) are the problem. In Sibelius' ";playback"; pane, there is a checkbox that says ";Tremolo:Play";. Select the phrase in question, and be sure to UN-check this check box. If you don't do this, Sibelius will send a series of midi attacks to simulate a roll, which will likely tax your CPU. Which is when you start to hear hiccups and pops/crackles.

If it's a single note roll, you can have VDL perform the marimba roll for you by typing the following ";technique text"; into Sibelius (at the moment you want marimbas to roll):

~C1,127

When you want it to go back to regular marimba notes, type ~C1,1

If it's a 2, 3, or 4-note chord that is rolling, I find it's best to enter in the actual ";rhythm"; of the roll into voice 2, then hide it, then select all notes in voice 1, and set them not to play by deselecting the ";play on pass 1"; checkbox. Just some concellations that need to be made for marimba rolls.
How many marimbas are rolling at once?  Are you actually writing out the roll as it would be played, or are you using tremolos on the beam?
Login or Signup to post a comment