Mac With Sibelius Users

I just bought a new iMac over christmas.  I was previously a windows user so i am adapting to the mac pretty quickly, its a much better system but it has its problems.  It has 1 gig of ram, and when i load over three instruments i get some extreme lag. Should i buy ram expansion and take it up to 2 gigs?  But the good thing is everything virtual drumline wise works. Sibelius on the other hand is really goofing up. i decided to ask this on the VDL 2 forum cause most of you guys know what your talking about, and might be able to tell me if my problem is related to VDL2 (which i highly doubt).  Alright, when i go to put a note in i enter the note, and very shortly after sibelius automatically puts a note in a random spot next to the note i just entered.  It does it for every staff.  I dont know why, but i cant seem to find whats making it do what its doing. If any of you know somthing please help me out.
Connor Powell

Upgrading your ram to 2gigs or 3gigs would make a huge difference not just with vdl2 , but all of your other programs as well.  I have a Macbook Pro with 1gig of ram and I haven't noticed much of a lag, but even so, I'm still planning on upgrading my ram just in case.  Another thing you can do to see if it is in fact your ram, is to check the activity monitor in your  utilities folder. While your running vdl2 and Sibelius, check the monitor to see if it is peaking out. And I do believe there is a little area on the kontakt player that shows your cpu usage while vdl2 is running. But just know, the more ram the better. On the Sibelius matter, I'm clueless. I'm sure help will be on the way. Anyways, I hope I was of some assistance. Good luck.

-Darryl Jones
There's a lot of info on this forum about getting the most out of your system, so much sure you use the search feature.

That said, 1 GB is not enough for a full drumline, so make sure you are using the lite instruments.  Also check the updates page at and download the DFD file.  You might need to break it down by sections and mix together later.  I made my ";deployment"; demo on a Mac mini with 1 GB of RAM just to see if it could be done.  I had to make an AIF file with only the battery, then only the ";woods"; and then only the ";metals"; and then mixed it together. 

If you get 2 GB that should be enough for a full percussion section with lite instruments.  You also don't actually need to load 4 marimba instruments if you have 4 in the pit, etc.       
Be sure to educate yourself on the Universal Binary issue. Sibelius and Kontakt 2 (without the UB update) are not Universal Binary so they are actually running in Rosetta on your iMac which majorly slows it down (majorly? is that a word?). I could barely get my system to not peak out and that was with 2 GB RAM. Once I downloaded the Universal Binary Update for Kontakt 2 and got it out of Rosetta, there was a night and day difference in performance! Sibelius won't be Universal Binary until Sib 5 is released, who knows when that will be.

Both my iMac and MacBook Pro have 2 GB RAM and it seems to be plenty. I can load complete drumline plus band without blinking an eye. If you got the cash, I would DEFINITELY max out your RAM.

Good luck!
thanks guys, i think i am going to go ahead and get another gig of ram, but i still cannont use sibelius because it continues to do the thing stated earlier. i have no clue what to do
Connor - Extra notes appearing doesn't sound like a RAM issue. This sounds like it may possibly be something to do with your midi in/out settings in either Sibelius, VDL2, or possibly both. Please list what you have set in:

Sibelius>Play>Playback and Input Devices

VDL2>File>Setup>MIDI Input Interface

VDL2>File>Setup>MIDI Output Interface
On the issue of double entry... I actually think I've had the problem you're having and it's a quick fix. If you are using the apple IAC driver as your virtual midi cable and don't have any other midi input devices available, Sibelius has likely automatically chosen your input and output as the same thing causing a short loop. In the input box, you might see that the IAC is selected, either choose the one you would like or click in a blank space. Without the IAC cable selected, you probably won't have this issue. Peace... Hopefully I helped...
Login or Signup to post a comment