Latency problems with macbook

I finally got my ram upgrade  to 2 gigs and didn't think playback would be an issue but different voices drop out as the score plays back.
I know this is a common problem that can be helped with a sound card upgrade but I thought the new macbook's sound card would do the trick.
My score has  8 voices right now
snare, tenor, bass all lite versions
glock, xylo, marimba, vibes
and one combo racks
I've tried many variations of latency settings and I have also tried different preset DFD settings.
Is there a good external sound card that will work with the mac book? Or is there something else I can try?
Thanks,
Josh
[quote author=jcdawg link=topic=1516.msg7107#msg7107 date=1169142548]
[color=Purple]How about the instruments themselves?  Are they all up to ~32 voices?  You may have set ";all"; to
Jim,
When you say ";max voices"; is that different form the ";reserved voices"; under the DFD settings? I've been changing the reserved voices to 256 and hit apply but when I go back and check it always goes back to 248. [/quote]

Reserved Voices is what I was referring to. After you click ";apply"; if you change other settings in the DFD window, it will alter the Reserved voices setting you made manually. So do this step last. If something else is affecting this, it may not be a big deal 248 to 256 isn't a huge difference. Ultimately, you may find it best to turn DFD off so you'll be loading all sample data to RAM. As such, make sure no other programs are running (exceptVDL and your notation program). Gotta keep those 2G's of RAM accessible.

What you should probably spend some time doing is evaluating the areas where you hear dropouts. Instruments like vibes, and marimbas, as well as instruments that sustain like glock, cymbals, gongs, etc can often be the biggest culprits of contributing toward this. This is because while the instrument is decaying, it's still utilizing polyphony.

Try playing only the keyboard stuff. Any luck? If so, add one battery staff. Still working? If not, mute one of the keyboard staves, and try again. Try to do a little detective work to see where the dropouts are happening, and what instruments may be a contributing factor. That will be helpful. Also, while we're sniffing around, please list all the settings from your VDL Soundcard setup window.

Are you using any other sounds in addition to VDL (for other staves)? I may have missed it, but I don't recal what notation program you were using. If using any of the Kontakt Player sounds within Sibelius, there are some settings you can alter there to help performance as well.

I'm sure there is a solution. This won't be nearly as much a problem when the Kontakt Player 2 update for VDL2 is released (no date yet).
[img]http://cityofrain.com/images/vdl2.jpg[/img]

This number.  Make sure that, for example, if you have 256 overall, and 8 instruments, then you should have 32 in here (or so) -- [256/8=32].
[color=Purple]How about the instruments themselves?  Are they all up to ~32 voices?  You may have set ";all"; to 256, but if each is restricted individually, it doesn't help...[/color]
Drumcat,
I don't understand can you explain more?

Jim,
When you say ";max voices"; is that different form the ";reserved voices"; under the DFD settings? I've been changing the reserved voices to 256 and hit apply but when I go back and check it always goes back to 248. Also I should have mention in my first message that I have been using the lite versions all along.
I did try adjusting the release knob, no luck.
So in summary, I'm still getting dropouts after trying all of the previous solutions. I was able to get it to playback with a really high Latency but the playback was less than desireable.
Would it help if I got another program like cubase?
Or is it possible to get a better sound card for a macbook?
Thanks again for all your help,
Josh

[quote author=jcdawg link=topic=1516.msg7085#msg7085 date=1169053526]
Jim,
Thanks for the speedy reply! I first tried loading all my samples sounds directly to ram by disabling the DFD. I set my latency to 20ms and made sure my sample rate was 44100 but once again no luck I then continued to increace the latency to 30, 40, ext.. until the clarity of rhythms began to be an issue. I then tried the DFD again and set the reserved voice setting to 256(by the way every time I went back to check that setting it would always go back to 248). Once again no luck. Do you have anyother suggestions?
Thanks,
Josh
[/quote]

If the ";max voices"; isn't holding to 256, my guess is that you didn't click ";apply"; to save your changes.

What instruments are you using? If any of them have a ";release"; knob on them, try lowering that. This will give you  more polyphony headroom in cases where you're exceeding more than your machine can handle. In case you aren't already, be sure to try using the ";lite"; versions of said instruments as well.
How about the instruments themselves?  Are they all up to ~32 voices?  You may have set ";all"; to 256, but if each is restricted individually, it doesn't help...
Jim,
Thanks for the speedy reply! I first tried loading all my samples sounds directly to ram by disabling the DFD. I set my latency to 20ms and made sure my sample rate was 44100 but once again no luck I then continued to increace the latency to 30, 40, ext.. until the clarity of rhythms began to be an issue. I then tried the DFD again and set the reserved voice setting to 256(by the way every time I went back to check that setting it would always go back to 248). Once again no luck. Do you have anyother suggestions?
Thanks,
Josh
With DFD settings the presets are ok, but be sure (in addition to the preset) to up the ";maximum voices"; to 256, then click ";apply";. Without doing this, you'll almost surely hear dropouts, even possibly with only 8 instruments loaded. What do you have latency set to? Also, double check to make sure your sample rate is set to 44100.

Here's another thought. Since you just beefed up your RAM (good call, even though you haven't maybe yet felt the effects yet). Try just deactivating DFD in the VDL player. DFD in the Kontakt 1.5 engine (which is what the current rendition of VDL2 uses) isn't nearly as reliable as the Kontatk 2 version (which will be built-in to the upcoming VDL2 KP2 update). In the ";options"; window, just make sure the ";active"; button is off (under DFD settings). Instruments may take a little longer to load, but going straight to RAM may curb any bottlenecks you're seeing in your MacBook.
Login or Signup to post a comment