Installation Errors

First Lesson:  Use the search function.

I was halfway through my original post when I realized I hadn't searched for my problem yet.  Sure enough, I found [url=][u]this thread[/u][/url] and it sounds very much like what's going on with me.  The first time I installed I put the main program file application on the C drive and tried everything else on my second drive (library, vst, etc.)  Error on startup.  The second time I put everything on the second drive: error on startup.

My question now is, I've read (at least I believe that I'm remembering correctly) that it is recommended to install the VDL2 library on a different drive than the OS for better performance when using DFD, which I'll probably have to do until I can get ram upgraded.  But if not using the default install path causes errors on startup, how can I go about moving the library?

(Man I hope that made sense.  I know it kills me to read a post without enough details.) 

One more question:  Has anyone else experienced this issue and fixed it with the default path install?
Keith - If this is the error I think it is, don't worry. It looks more intimidating than it is.

Is this the error?:

  [i]  WARNING: could not open content file!
    It should be located at xx;xx;xx;xx;etc

    Would you like to select a different directory now?[/i]

If so, all you have to do is tell the program where you've moved the library folder to. So either click ";Yes"; on the above message (when you get it), or if you're already in VDL2 (with no sounds) click the ";path to library"; button within the ";Options"; screen.

Simply navigate to the folder called ";Virtual Drumline 2 Library"; (highlight the folder, not its contents), and click ";choose."; Once you've done this, you should now see all the instruments available when you click the ";load"; button, and next time you launch VDL2, you won't get the error message.
Sadly, the error is the dreaded ";Virtual Drumline has generated an error and must close"; and that's it.
Darn - so much for my ";simple"; fix.

I'm not sure i have a quick answer for you, but it would be worth a [b]full[/b] uninstall, then reinstall. According one user on the post you referenced, he had better success avoiding Windows' ";add or remove programs";, but instead running NI's uninstall from VDL2 installer. Honestly, I've never done that before, so I'm not sure about it. For the very few who've had problems it seems that doing ";add/remove programs"; from Windows control panel, doesn't remove some things that are important to have removed. I recall seeing some discussion on that here recently, so maybe do some more searching.

The other thing you can do is contact Native Instruments Tech support with their online form at:

Or try calling their [url=]Los Angeles support line[/url] between the hours of 9-5 PST.
I found that post earlier today so I haven't been able to try the full uninstall through NI yet.�� But like others I had no luck with the ";add/remove"; in Windows.��

I'll try the full uninstall tonight and report back.  Thanks!


Hello!  Also try running a virus scan and a spyware program.
Sometimes those ";must close now errors"; might be caused by
either a virus or spyware.  I defrag my computer every
evening or early morning.  What I have offered might not
be the fix, but it certainly cannot hurt.  Then again,
in the wonderfully frustrating world of Windows--who knows?
Good luck with your problem.

Take care!
Update:  No luck with the default path install.  Updated the Kontakt Player to the latest version with no luck either.  I've contacted NI via their online form and I'm waiting on a response.

(I keep telling myself:  Just another reason to get a Mac.)  :)
Keith - while you're waiting to hear back from NI, have you checked some of drumcat's suggestions here:

Since you're using a Creative Labs soundcard, there might be something with that causing a conflict. There are some technical troubleshooting tips he offers that might yield some more info. I do have a hunch this isn't related to your NI software, so it'll probably serve you well to continue searching for the conflict in the meantime.
Thanks Jim.  I'll get started on drumcat's suggestions.

I guess I should have explored this sooner, but per drumcat's suggestions a clean re-install of my soundcard did the job.  There's still seems to be a minor issue somewhere, though, because after I chose the Creative ASIO driver, the ASIO config option caused that same error.  But as long as I stay away from that there it isn't a problem.  Should I worry about this at all if everything is ok otherwise?  I haven't gone to the creative site to install the latest updates to everything, because to be honest if everything is working I might just leave it alone.

Now all I have to do is get past the initial clumsiness of inputting via the midi keyboard and I'll be good to go.  Thanks for the tips everyone!
Great news Keith. When you re-installed soundcard drivers, did you install the latest versions? I would tend to think that's the best course of action so you're current with the most reliable drivers. ASIO is typically the driver format you want to use, so ideally you'd want that to be functioning well. Glad to hear progress is being made though!
I've not updated the drivers yet, but I plan to do that as soon as possible, as opposed to just leaving it alone (as was my original plan).  In all actuality I'm not the type of person that can just leave stuff alone if I know something is a miss, even if it doesn't [i]appear[/i] to affect performance.

Hopefully soon I can post back with everything as it should be.
Login or Signup to post a comment