Latest developments

Hopefully these are positive signs.  I went ahead and opened sibelius & the VDL 2 Template.  Then I opened VDL2.  I went ahead and loaded marching snares and tenors.  After this, I put in some simple rhythms with no problems.  Next, I clicked play.  Even though I still can't hear anything, the mixer showed the green light going up/down which showed me that it is playing.  Now, I just have to fix one more thing to get that sound. 

In my sibelius playback, everything is set off except midiyoke: 1 for output.  In my mixer, everything is set for midiyoke:1. 

Sorry to be a pest gentlemen, but I know I am so very close to having everything running correctly.  Please send any further ideas.  If I don't get back on here for a couple of days, it is because we are going out of town.  Maybe the time away from my computer will be beneficial.

Take care and again much thanks,

Dennis
Jim ,

Everything is working.  A sibelius tech (Sam) gave me a completely different set of instructions and these worked the first time.

I am sending these on this reply, so you can see what I had to do.  I didn't need to reload any drivers or such.  But the instructions, I followed.  Here is his post.

[b][i]Dennis,

This all points to a driver conflict when you have 2 programs open. Once you have done this the Kontakt Players (VDL 2, Kontakt 2 etc.) remember that no audio outputs are available so then the next time you try and run it you get no sound, even if only one thing is trying to access it. It would be best to reset the VDL 2 Kontakt player and Kontakt 2 back to 'zero'. Uninstalling and reinstalling will fix this but there's a quicker, and more adventurous, way:

Quit Sibelius, VDL 2, Kontakt 2 etc.
Go to Start, Run and type in regedit and click OK.
Navigate through the + signs on the left to HKEY_CURRENT_USER\Software\Native Instruments and delete Kontakt2 and Virtual Drumline 2.

Close the Registry window and start VDL 2 again. Choose MIDIYoke 1 for the MIDI in (not your keyboard/AP MIDI) and choose the Audio output you want too. See if you get sound.

Quit VDL 2 and start Sibelius. Go to Play, Playback and Input Devices and click on Kontakt Player Options. Make sure 'Use Kontakt Player (if installed)' is unticked. If so, good. If not, untick it and restart Sibelius (waiting 10 seconds before restarting). Once Sibelius is open go back to Play, Playback and Input Devices and set the Playback device to MIDIYoke 1. Click OK and open a score.

Open VDL 2 and load in a sample into slot 1. You should find that these sounds get triggered off when you play things on the stave in Sibelius that's assigned to channel 1.

That's the principle anyway! If you find things still don't work then you should probably uninstall and reinstall the Audiophile's drivers and software. You can get the latest version of these from http://www.maudio.co.uk/index.php?do=support.drivers

Another thing to try is to uninstall MIDI Yoke and install Maple MIDI, which does pretty the much the same thing: http://www.hurchalla.com/Maple_driver.html

Hope this has pointed you in the right direction.

All the Best,

Sam [/i][/b]

Jim,

Thank you and also to everybody else for their help.  I cannot wait to get writing.  I'll let you know how it goes.

Enjoy your weekend!

Dennis
I'd suggest that Dennis. Use Kontakt Gold for your wind/brass sounds. Do this by setting those tracks to ";Kontakt Player"; within the Sibelius mixer's ";device"; pulldown menu.

A couple suggestions to ensure you'll get the best performance:
- Use ";Eco"; instruments
- Try to avoid using Reverb with the Sibelius Kontakt Player
- Have common instruments share the same slot so less instruments have to be loaded into Kontakt Gold (which will help save some RAM headroom.

One other thing when you're setting your channels for Percussion staves, just ignore the setting in the ";sound"; field. Since you're not using GM percussion sounds, you can just ignore this.

Good luck!

Jim,

We just arrived home, so I hope to try the suggestions you made.  BTW, I have been so concerned about the percussion sounds, that I forgot to ask how I should have my woodwind/brass set on the mixer.  Should I use kontakt gold for those sounds?

Dennis
I'll try it when I get  home on Friday.  We're just getting ready to leave for a couple of days.

Thanks,

Dennis
That helps greatly Dennis. Thanks! Looks like all you need to do is set your channels correctly. Everything else looks correct.

Let's assume you're trying to load a concert snare drum sound for now.

1) Load the desired snare instrument (concert SD for this example) into VDL in any open slot. Set it's channel (1-16) using the MIDI-IN selector in VDL (just under the CPU usage meter). Just for kicks, set it to channel 3. You can set it to any channel.

2) In Sibelius, set the corresponding snare staff (in the Sibelius mixer) to channel 3 (not channel 10).

3) In Sibelius, select the first measure of said snare staff, and set the correct ";staff type"; per the instructions listed in the template. In case you deleted them, you do this at:
Create>Other>Staff Type Change>Percussion> VDLxxxx (concert SD, or whatever instrument you're trying to display).

For any other percussion instruments you want to use, be sure they're each set to their own unique midi channel so they don't conflict with one another. The midi channel in VDL must match the channel setting in Sibelius Mixer for that staff.

Hope this helps.
Hi Jim,

Sorry for being late with this information, but just got back in.

Here it is:


* VDL>File>Setup>Soundcard (list what you have set there, as well as any other options to choose from)-  [b]Choices include:  ASIO, Direct Sound, Multimedia.  It is set at ASIO.[/b]


* VDL>File>Setup>MIDI (list all available options, and which ones are set to ";on"; or ";off";)-  [b]Options are:  MidiYoke NT:  1,2,3,4,5,6,7, and 8.  Also, Delta AP Midi, and microsoft GS Wave SW Synth.  It is set to Midi Yoke NT: 1
[/b]

* Sibelius>Play>Playback and Input Devices (list what's available under 'playback devices', and which is set to ";Use";)  [b]Sibelius playback devices I see are:  kontakt player, Midi Yoke NT:  1-8, Delta AP Midi, and Microsoft GS Wavetable SW Synth.  I have it set to Midi Yoke NT:1[/b]


* Sibelius>Play>playback and Input Devices - under ";input device"; list what's available, and what's selected.  [b]Devices I see for Input are:  Midi Yoke NT: 1-8 and Delta AP Midi.  I have Delta AP Midi selected.
[/b]

* Sibelius>Play>Mixer - Select a percussion track - what is set under ";device"; and ";Channel"; settings?  [b]Under mixer, I have selected for the device Midi Yoke NT:1.  When I went to Snare Drum, the channel listed is 10 and the sound is standard kit.[/b]


I hope the above answers help.

Dennis



Dennis - it sounds like you're confusing the [b]latency[/b] setting in [i]Virtual Drumline[/i] (the standalone program), and [i]Sibelius[/i]. But I don't think this has anything to do with why you are not hearing sounds. You say your settings are right, but if it's not working, clearly you're settings are [i]not[/i] correct. So rather than going back and forth on the boards here which is causing you frustration, I think it would be worth the extra few minutes for you to list the following settings for us since we can' t actually see what you're settings are.

* VDL>File>Setup>Soundcard (list what you have set there, as well as any other options to choose from)
* VDL>File>Setup>MIDI (list all available options, and which ones are set to ";on"; or ";off";)
* Sibelius>Play>Playback and Input Devices (list what's available under 'playback devices', and which is set to ";Use";)
* Sibelius>Play>playback and Input Devices - under ";input device"; list what's available, and what's selected.
* Sibelius>Play>Mixer - Select a percussion track - what is set under ";device"; and ";Channel"; settings?

It is absolutely crucial that each setting be [i]knowingly[/i] entered correctly. One wrong choice can render your setup useless.

When I first started navigating musical roads with this type of technology, I eventually realized the car always worked fine. It was the driver that needed the most help. :)

[quote author=drumcat link=topic=1618.msg7739#msg7739 date=1173806071]
I get the feeling you're missing a step.  Check this one... 

In Sib4:

Play > Playback and Input Devices, Playback tab.  You should see your midiyoke in there; be sure the one you're using says ";YES"; in the ";Use"; column.
[/quote]

Drumcat,  this was set yesterday.  Like I've been mentioning over and over, my settings are correct.  However, I did notice that when the I have VDL2 ";Standalone";, the audio setup shows a number in the latency column.  When I bring up the sibelius, it does not.  I've tried to add latency in the sibelius, but no luck. 

I am going to try talk to Bill Castillo tonight.  Maybe he can talk me through this on the phone.

I appreciate everybodys help, but this is getting frustrated.  I've never had this many problems before.

Dennis
I get the feeling you're missing a step.  Check this one... 

In Sib4:

Play > Playback and Input Devices, Playback tab.  You should see your midiyoke in there; be sure the one you're using says ";YES"; in the ";Use"; column.
Two things happened this morning:

1.  Was able to get sound again from VDL2 ";standalone";

2.  Able to input notation using midi keyboard.

Quick question:  When I use the pull down menu to set my sounds/playback in sibelius?  Under Midiyoke, should I be selecting Standard drumset ? 


Still no sound on playback of rhythms that I have inputted.  Should I reload the template? Any ideas?

I am so close, but yet no cigar.

Dennis
Login or Signup to post a comment