Playback stumbles...

Ok, I have an 24"; iMac, 2 GB RAM, 500 GB HD, and Kontakt 2.2

About 90% of the time, the playback works like a charm.  However, there is that 10% where it doesn't, and I am wondering if anyone can help me with this.

I am running Finale, have a complete Marching band Score.  16 Band instruments, plus a full drumline (pit and battery).

I have the latency at 50ms, each voice is set to a polyphony setting of 10, DFD is turned on all the way.  I will listen to the same tune 5 or 6 times.  I will keep an eye on the CPU and Disk meter in Kontakt 2 and most of the time it hovers at less than 1/3 of the meter for both.  However, on the 5th time, I will get a spike in the middle of the tune, and the CPU meter runs in the red and so does the Disk meter.  It lasts for a few seconds then everything goes back to normal.

While this isn't a big deal since I can hear it right most of the time, it does become a drag, because when I try to record the playback, this may be the unlucky time that it screws up somewhere in the middle.  I am wondering what causes this, and if there is a fix.  The only programs running at the time are Finale, Kontakt 2, Wiretap Pro, Finder and Dashboard.  Is there a way to prevent this from happening?

Any help will be greatly appreciated!


P.S. - I do know about loading the Lite versions of each instrument, however, the parts that seem to cut out when things go wrong are the band parts, not the drum parts.

My first thought is that it is a polyphony problem, possibly too many notes or midi messages choking the whole process and causing the cpu spike. Try setting your polyphony for the keyboard instruments higher.  Long sustained sounds such as vibes and glock will eat up the polyphony. If it were a latency issue you would also have pops, crakles or distortion to your sound and it would be more consistent.

One other suggestion is to turn dashboard off. This can be done by downloading a freeware app available at the Apple site. Because dashboard is ";always on"; it can cause playback to be interrupted similar to your problem. Hope this helps a little.

Ted Boliske


Which version of Finale are you using?

When the playback ";stumbles";, are you hearing:
a.) voices dropping out?
b.) lost playback quality?
c.) hiccups in the playback tempo?�� ��
d.) all of the above

[u]A few Finale things to check (in order of most to least obvious) would be:[/u]

1. Make sure each wind stave has its own channel.��
-If you want to take this to the next step, you can notate [i]divisi[/i] wind parts on seperate layers/channels so all instrument patches are monophonic.

2. Turn off Human Playback. If you are using HP, it will struggle even more if my first suggestion is not taken care of.

3. In the Instrument List (from the Window Menu) make sure 'Send Patches Before Play' is checked.��

4. When you are ready to make your recording, uncheck 'scrolling playback' in the playback controls drop down.
Scrolling playback has been known to take away from your CPU which could be causing the intermittent bog-downs during playback.��

Some good suggestions all around.

With DFD settings in Kontkat 2, putting the slider all the way to the right doesn't necessarily guarantee the best performance. You might fiddle a little with putting it not quite all the way right. There's also a document in your Kontakt 2>Documentation folder called ";DFD Demystified"; which may provide some helpful input on the strange beast of disk streaming.

If you don't want to mess with shutting Dashboard completely off, at least make sure all widgets are closed. This will help free up some resources. It may not be the cause of your problems, but certainly can't hurt. Dashboard is cute, and can be useful sometimes, but it shure would have been nice if it didn't *have* to run if you didn't want it to.

Very wise of you to observe the CPU and Disk meters. As you're monitoring these, keep in mind where spikes may occur. Do they happen in the same phrase when they do happen? If so, it may be the density of the score at that point. With a full band, pit, drumline, you'll be churning out a lot. So thick phrases will certainly be more likely to max out your resources.

In regard to LITE instruments, you may find the vibes and timpani especially helpful since by default, they have a little less decay time after notes are released, which can clear up your polyphony in more active phrases.

Keep us posted. I'm sure there's a solution for 100% reliability.

Let's see where to start with the answers.

I am using Finale 2007
I hear all of those problems listed above, however, it only lasts for about 5 seconds.
Every instrument is on its own channel
HP is on
Send Patches before play is checked
Good point about turning off Scrolling playback.  That crossed my mind, although I have not done it yet.

Before I read Jim's post, I did fiddle with the DFD slider.  I did notice how about 3/4 of the way gave me more voices, than all the way.  So I did fix that.

As far as consistency, there is no consistency of it happening at the same place.  I am thinking it has some to do with the Auto-save function in Finale.  Tried turning it off, and it helped.  Now instead of it lasting for 5 seconds.  When the spike does occur, it lasts for 2 seconds or less.  It very well could be the scrolling playback, and I am sure the HP.  However, if I want diddles to play, don't I need HP on.

Also, I did did go through and turn the metallic (Glock, Chimes, Vibes) instruments polyphony back to 32.  Kept all of the band stuff at 10, and it seemed to work better. 

Like I said the playback stumble would occur about once for a brief moment every 5th or 6th time of playing things back.  I have noticed with the new setting, it lasts so much less time.  I will attempt to the lite vibes to see if that improves things. 

Thanx for everyone's help!


P.S. Has anybody had this problem with Sib.  If you human playback is the problem, I know Sib does a much better job of playback.  However, the only thing I think Sib has going for it, is the Tremolo tool (the way of putting them into the music).
Glad to hear you're making some good headway Robbie. I hadn't thought about disabling ";auto save"; but that would seem like a great idea. If you're like me, you have an impulive 'command S' jolt every minute or so anyway when no need to auto save.

If you turn off HP, I believe you can still get your diddles to play back using the TG Tools plugin (in the plugin menu) called ";smart playback."; It will put invisible notes into layer 4 which will account for the diddles. The only drag about that (no pun intended) is if you later decide to change a part, you'd then also need to delete the stuff in layer 4, then re-run the plugin for anything you've changed. Not super elegant, but it's one possibility if you decide to disable HP.

The Sib vs. Fin debate is probably another can of worms. There are many differences in the two programs. But since  both are essentially aiming to accomplish the same goal (notation), I think the best general rule would be to use what works best for you.
Finale's Auto Save also, in its own right, open another can of worms.  People will often use this and then open up their file twice and then Auto Save can save both of those files resulting in loss of work.  I would suggest in not using Auto Save and then, like Me, using your Command-Shift-S twitch.  I do a SAVE AS...after every major change I do to a score.

- Just my 2 Cents about Auto Save.

I am with Ted.  It sounds like a Polyphony issue to me.  I can run into this even with 2GB and a full drumline score.  I had the same problems at a time when I was u sing Sibelius, so Sibelius probably wouldn't help you anymore.

I get very good real-time playback from Finale with a full score.  I would follow the steps that Ted gave about adjusting those Polyphony numbers to see if that helps.
Some info for dealing with Dashboard. There is a freeware app called 'Dashboard Manager' which allows you to easily turn Dashboard on and off. It can be found at Just type in 'dashboard manager' in the search window.

Ted Boliske

p.s. turning off Auto Save in Finale is the first thing I do after installing and registering the new versions.
Unfortunately, you'll find that with even the most streamlined tweaks available sometimes you'll run headlong into the limitations of your system.  Simply put, sampled playback is quite memory and processor-dependent, and even with very adept systems you'll run into occasional hiccups.

One thing to note is that the particularly RAM-intensive nature of sampled playback plays to both a strength and weakness of OSX, which is its memory model.  If you check out Activity Monitor, you'll see that OSX frequently gobbles up its available physical memory to cache data for fast access (which is called ";paging in";).  When it's largely full, data must be removed from memory to allow space for new data (";paging out";) which comes as a slight performance hit.  While several gigs of RAM is plenty fo most day-to-day tasks, a lot of paging can make a slight dent in the zippiness of OSX and particularly something as intensive as sampled playback.  That's certainly a little tangental, as I agree with the above posters it sounds like a Poly error to me, but worth mentioning since a lot of people seem to live by the ";reboot if things get slow"; mantra and that's one of the reasons why it is that way.
Login or Signup to post a comment