Yes, another Kontakt 2 question...DFD issues

Sirs,

I'm using:
Dell XPS @ 3Ghz
2 Gb memory
Soundblaster Audigy 2 card
Kontakt 2 v 2.2.1
Sonar Cakewalk Home Studio 4
(Sibelius 4)

I've made a Sibelius 4 file for battery and pit (14 channels).  I'm using Kontakt 2 as an ";inserted"; DXi into Cakewalk for recording purposes.  Whenever I attempt to export the audio to become a .wav file,  I get several ";Not enough DFD memory! Sound will not be started!"; messages.  So, I went into Kontakt and have messed with the DFD allocation slider what seems to be a ridiculous amount of times, but I continue to get these out of DFD memory messages.

The things I've done:
I've turned off reverb on all instruments.
I've done some instruments from DFD, and some from ";sampler.";

My current DFD settings are: 230 MB allocated for DFD streaming voices; max # of voices playable, 420.  Output latency is 20 ms.

Every time I try to mess with the ";expert mode"; my computer ends up freezing, following the dreaded ";cannot allocate this amount of memory.";

Any help would be greatly appreciated...

Shawn
Shawn - have you attempted to adjust your audio buffer (latency) settings within Cakewalk? This could have a lot to do with how well your CPU (and in turn, DFD) performs. You mentioned output latency being set to 20ms, but I want to be sure you're making this setting within [b]Cakewalk[/b] (your host), and not in the stand-alone version of Kontakt as that won't have any affect on a hosted version of the Kontakt plug-in nor how it performs in a DAW. All audio settings would have to be adjusted in Cakewalk itself, so if you haven't already, check the various audio hardware settings there.

Also, keep in mind, if you're going to remove reverb and set some instruments to ";sampler"; (rather than DFD) you should first be sure to click the ";edit all groups"; button, or you really may not be altering the settings of the whole instrument as it may seem. These adjustments are certainly more tailored for folks who don't mind ";getting under the hood"; a bit, so that's the only reason I bring it up as certain aspects to the way instruments are programmed may not seem immediately obvious.

Also, it's unclear on how you're creating your audio. Are you using Sibelius and Cakewalk simultaneously? If so, this could be one reason you are getting low on RAM, but I'm not sure. If you're working strictly in the Cakewalk environment, is there a way to bounce your .wav in ";offline"; mode? If so, the problem might not come up as it won't be churning out all the audio in real time.
Jim,

Thanks for your (as always) trememdously helpful response.

I hadn't, until now, realized that I needed to adjust the latency setting from within Cakewalk.  So I've done that; it now sits at 20ms within Cakewalk.  (Cakewalk Latency was set to 100 ms, I believe). Also, ASIO was not the default driver set in Cakewalk-it was the ";WDM/KS.";  So, I've changed that as well.

So, I no longer am receiving the DFD error messages as I was before.

Feeling brave, within K2 I've tried moving all instruments back to DFD, as opposed to some voices from sampler and some on DFD.

To clarify, I'd one my score in Sibelius 4, using Kontakt 2 as my output.  Then, I saved as MIDI.  Closing Sibelius, I open the Midi file in Cakewalk, using Kontakt 2 as an ";inserted"; DXi.  So the only programs running at this point are Sonar and Kontakt 2.

I am still getting dropouts and crackles within the created .wav file, though it is better than before.  It sounds like the ";not enough polyphony"; settings that we newbies sometimes get, but all polyphony settings look OK. What other adjustments may be necessary?

Here's what's currently set (within Cakewalk):
I/O buffer size: 128 K
Driver Mode: ASIO
Dithering (um...what?): rectangular
**I've also clicked a box that says ";Share drivers with other programs"; Should I un-check that?
**I've clicked a box that says ";enable read caching"; as well.....
Sampling rate is 48000, which is what my Soublaster Audigy  2 uses
File bit depth is 16

As a side note, what is ";bouncing"; to click, vs. ";Bouncing to track?";

Shawn
Hey Shawn, can you post a clip of the audio?  I'd like to hear the resulting problems...

In the meantime, I'm wondering something out loud here, ok?  When you export your audio in Sonar, is it possible you have ";fast bounce"; checked on in the Sonar export settings?  It's the last one...  If you do a fast bounce, you could be subjected to junk in the audio, since it goes fast, faster than maybe your hardware can.  If you do a ";slow"; bounce, Sonar slows down to the point that even if it takes longer than real time, it makes sound quality the most important.

Bouncing to a track generally is when you take a midi channel, and create a duplicate wav channel.  There are reasons for doing this, particularly because you can add effects to audio that you can't to midi (data).  Exporting, or bouncing the whole thing, should give you a summary wav of everything.  The ";to click"; part, I'm not sure; I'd have to see that in context...
Login or Signup to post a comment