Recording Problem

I recently received VDL 2.5 and have been having problems actually recording my playback.  When I use VDL 2, I play back the sounds using Finale 2002 and I leave the DFD option turned off (When I tried turning it on, voices would be cut short, or cut out altogether).  During playback, I record using #1 Sound Recorder, which has always worked fine. 

Now that I [i]have[/i] to use DFD with VDL 2.5, the playback works fine (obviously I'm using less RAM), but when I try to record the playback, voices (specifically sustained voices like Chimes and Sus. Cymbal) are cut short.  When the battery and pit are playing together, many of the voices drop out altogether.  Any insight into this problem would be much appreciated.  Thanks.

Windows XP
3200+ AMD Athlon XP Processor
1GB RAM
200GB Hard Drive (119GB free)
VDL 2.5
So... I was trying to play back an ensemble the other day on VDL 2.5 (which I had previously and successfully recorded on VDL2), and I ended up having voices drop out again.�� After playing with settings, I finally broke down and decided to get some RAM.�� I now have 2GB of RAM, but it hasn't helped my playback, much less the recording.�� The DFD meter is still maxing out more than the CPU meter.�� Any suggestions would be greatly appreciated.

Also, I got an offer to upgrade to Finale 2008 for a decent price.�� You can host the VDL 2.5 sounds in that program right?�� If that's the case, then does that mean I could save the file as a MIDI (or some other audio file), while maintaining volume, pan and reverb settings, and not have to worry about faulty playback (running a separate recording program)?
Audacity [i]definitely[/i] helped.�� I think between that and ASIO4all I have things working a lot better.�� The Disk meter is still maxing out at times, but the voices aren't dropping out anymore and I managed to get some good recordings.�� It still needs some tweaking, but i think I've got things under control for now.�� Thanks for the help!
My hunch is that a better sound card/audio driver would give you better performance. DFD is demanding on your CPU, so when you combine that with less efficient audio drivers, you're probably making your system work pretty hard. Check out the Audiophile 2496 if you're using a tower with PCI slots. Maybe before you upgrade your hardware though, check into the ASIO4all driver to see if it gives you better performance than the DirectSound driver (http://www.asio4all.com).

Also, keep in mind that your hard disk is being asked to do a lot here. It's being asked to stream samples to playback (DFD), and additionally, it's being asked to record audio (No. 1 sound recorder). As Cadet311 mentioned, it's possible that recording the audio to an external disk could help during the recording process. You might also look into Audacity (free) to see if it performs better than No. 1 Sound Recorder. I have limited experience with both so wouldn't be able to give you much guidance there.
I checked the CPU and Disk meters during playback:

Playback only:��
CPU:�� 4 or 5 bars max
Disk:�� 2 or 3 bars max

Recording playback:
CPU:�� 4 or 5 bars max
Disk:�� Red bar on the right side of the meter only (seems to be maxed out the whole time)

My PC's hard drive is 7200RPM.�� The sound card is DS Realtek AC97.�� I was using DirectSound, but I found the free download of ASIO and I thought I might try that (if it works).�� I thought I mentioned that I was using Finale 2002.�� It's an older version, but it gets the job done...�� Anyway, I'm really thinking about maxing out the computer's RAM, but I want to make sure there are no other solutions first.
If you've got an external HD, try recording to that.  I know that has helped me with difficulty in recording large charts.
While this playback is occurring, position your windows in a way so you can view the CPU and Disk meters (near the top right hand corner of the KP2 window). Let me know how they seem to be performing as they can give you a sense of how hard your CPU is having to work to perform. My guess is that things might be getting taxed a bit, which is causing stream (note playing from DFD) to become interrupted.

Keep in mind, when I suggested a possible RAM issue, I wasn't referring solely to RAM allocated to samples. Rather, running windows, KP2 (with various samples loaded), your notation program, and a sound recording program (and these are the bare minimum based on how you're doing things) may be pushing the limits of what you can do on 1GB RAM.

Couple other areas that could be worth looking into:
1 - Are you certain your hard drive spins at 7200RPM? Less than that can cause difficulty in DFD streaming. Most laptops ship with 540RPM drives, which is a
common reason laptops don't perform as well as desktops.

2 - What type of audio driver/soundcard are you using? Lower performing audio drivers like MME or DS can place much more burden on your CPU than using an audio card that was meant for this type of performance that uses ASIO or Core Audio drivers. If you're not sure what I'm talking about, check the ";interface"; and ";device"; settings in the KP2 ";soundcard"; setup window.

3 - Try going through and applying the ";Tuning Tips"; at: http://www.musicxp.net/

4 - I'm still not sure if you're using Finale or Sibelius, but try turning off scrolling when you record. Screen redraws can steal CPU resource.

Keep us posted on how things are getting on for you.
I increased the DFD slider and lowered the release knobs, and it helped a little, but I still can't record without voices quitting on me.�� I don't [i]think[/i] it's a RAM issue, because I was using twice as much RAM when recording with VDL 2, and it always worked fine.�� Like I said before, I had the same problem when I tried to use DFD on VDL 2 (the red light next to the instrument name would flash and voices would be cut short), then I added RAM to my computer and I haven't used it (DFD) since.�� I'm still fairly new to using DFD, so I'm probably missing something simple, but that seems to be where my trouble is.

Specifically, one of the scores I'm trying to record starts off with a Chimes (Hammer) solo, a simple whole note chord at 88 bpm.�� About half way through the measure (only while recording), the sound stops unnaturally.�� The same thing happens with vibes, piano etc.
Try increasing the DFD slider in the KP2 ";options"; window. That might give you some more simultaneous voices.

Also, on those instruments you mention (chimes, sus cyms, etc), try lowering the ";release"; knob on the instrument itself.

I assume you're running KP2 in stand-alone mode? If so, I'd also assume you have something like Finale or Sibelius running. Plus windows, plus No. 1 Sound Recorder. On 1GB RAM, this may be asking a bit much. When you're running all these programs at the same time, your CPU is having to work much harder, so it's possible this might be the case.
Login or Signup to post a comment