MacBook keypad issue

Hey guys, hope everyone had a great Thanksgiving.

I just purchased a MacBook, and have had issues with the 10-keypad. For instance, on my Powerbook, by selecting “fn + u”, that creates keypad number “4” (which is the simple entry for quarter notes in Sibelius). 

My “fn” button does work (as I am able to use it when switching to “dashboard” for instance), however, I cannot access the keypad (even in text edit).

Does anyone else have this issue? I know this is not a VDL or Sibelius issue, just looking for a bone (as I was on the phone with AppleCare yesterday for over an hour, with no luck).

Thanks

No kidding? Thanks for letting us know that MacBooks (but not MacBook Pro) is missing this feature. I hadn't realized that.

If you are going to get a keypad, be careful which one you buy. Certain keys on certain keypads don't behave properly for Sibelius. Check this post for more info:
https://www.tapspace.com/forums/index.php?topic=247.0
So it turns out, that the second generation MacBooks have no ";numlock"; or 10-key built in to the system. So it's an external keypad or nothing. (note, the MacBook Pro's however, DO still have the built in pad).

Please be aware of this if you are looking to purchase.
(note: I don't actually own a MacBook :))
I have seen reports online about keyboards not responding:
http://discussions.apple.com/thread.jspa?threadID=1217703&tstart=0
...but I think that is for the whole keyboard,  not just the number pad.

I'm pretty sure you would have noticed this, but you don't have ";num lock"; on, do you? (pressing 'fn' and the key does nothing in that case, while pressing it without 'fn' works for me)

You might want to double check your settings in the keyboard preference pane to make sure it isn't an option that is turned off. Does the keypad entry work in other apps? (like TextEdit)
Hey Jim,

I actually spent 30 minutes on the phone with Sibelius yesterday (my tech actually went and called in the ";mac specialist";). He had not heard of my issue (in the three years he has worked there), and after some trouble shooting, we figured out that it is a apple issue (as the keypad is not working at all).

Apple tech support (which was an hour and fifteen minutes of a waste) served as no help. I think I am going to schedule an appointment with a Mac Genius instead.

On a side note (which is apple related) it seems as though they (apple) have farmed out tech support overseas. Over the last month I have made about 5-6 calls for various reasons, and I always end up with someone who speaks poor English, and is reading out of a manual (and asking the important ";enlightening"; questions like ";is your computer turned on";). It�۪s a bummer, as previous apple tech support was in Cupertino, and handled by someone who as actually a Mac expert.
Vinnie - I'll be interested to see what you can dig up on this. I haven't actually accustomed myself to using the keypad with the 'fn' key, but it would stand to reason that this should work correctly. I think this would be a good question for the folks at Sibelius to see if there might be some glitches.

http://www.sibelius.com/cgi-bin/helpcenter/search.pl?com=main

Or possibly check the discussion boards at Apple as well. Maybe it's MacBook related:
http://discussions.apple.com/category.jspa?categoryID=218

Let us know if you learn more.
I was hoping to avoid the external keypad. Partly because of having something extra to drain battery life, but also because I am just so used to the built in keypad.

Keith, thanks for the heads up regarding input issues with Sibelius.
Just be careful about some keypads, as not all will mimic the actual numpad from a standard keyboard.  This can create minor input issues with Sibelius when using the top row and the USB keypads.
Vinnie

You may want to just buy a separate number keypad that you can plug into one of your USB ports. I have found this to very handy for me, as I don't have to mess with the ";fn"; key or the like. Actually, I never did figure out how all that worked anyway.

This is the one I have - I bought it at Best Buy:�� [url]http://www.dynexproducts.com/p-116-dynex-usb-numeric-keypad.aspx[/url]
I think I paid about $20 for it - and it's been worth every penny!

(That particular one says it's not Mac compatible, but you get the idea.)
Login or Signup to post a comment