Sibelius 5: Slot numbers sometimes change when adding new instruments

As the subject suggests, the slot numbers in the mixer sometimes change when adding new instruments.  I have been having this problem semi-regularly, and it seems to happen after a certain number of instruments have been loaded.

Not sure where the root of the problem is but here is the scenario:

[li]Working on a band score with 17 wind instruments (Sibelius Essentials) and 14 percussion instruments (VDL)[/li]
[li]After adding an instrument in one of the wind staves, my bottom percussion staff (which is Rack Combo B in slot 14), started playing the sounds on the line above it (which is Field drum in slot 13)[/li]

I'm not exactly sure what is causing this, but it has happened before with different instruments and a different number of staves.  Not sure where to start or if this is even the best place to discuss, but I figured this would be the best place to start.

Anybody else having similar problems? Thanks!
Sibelius 5 is designed to dynamically assign slot numbers on its own. Sibelius should be organizing the playback on it's own, and you shouldn't need to even look at the slot numbers (contrary to earlier versions of Sibelius). Are you manually assigning/changing slot numbers anywhere?
I understand how it works, I just don't understand why they are changing.  As far as I know, Sibelius 5 doesn't allow you to change the slot numbers, and I haven't changed any of the corresponding numbers in KP2.

Anybody else having a similar problem?
So when you play back are you not hearing the correct sounds then?

I'll be online later tonight Bryan, and we can chat about it some more and figure out the problem.

Did you get this figured out? Does it only do this when you add an instrument to the score somewhere?

One way to get things to ";reset"; properly is to switch to a different Playback Configuration, then somewhat immediately switch back to the correct one. This in turn ";forces"; Sibelius to reload ALL of the patches.

Hope that made sense. Let me know.
One thing you may want to try to check this out (if you haven't already) is simply adding another instance of KP2 to your playback configuration. If you don't have enough available slots for the amount of instruments your score requires, Sibelius will fall back on substitutions of instruments that are loaded.

Another thing to try experimenting with is whether or not it helps if you check the ";use same slot for common instruments"; setting in the playback area of the Preferences window. This can help prevent too many instruments from loading, and also reduce the amount of time it takes for a score to load everything.
Jim, you are my hero.

I loaded a new instance of KP2 and everything started running fine.  If anybody experiences this problem, that would be the first thing I would try.

Thanks again, Jim.  I owe you one... or more like multiple ones.
Login or Signup to post a comment