KontaktPlayer2/Sibelius 5.2

I can't seem to get KontaktPlayer2/VDL 2.5 to show up in my Playback Devices menu in Sibelius. As usual, I'm sure that I skipped some mundane detail that has created this situation. I would greatly appreciate any help.

Matt Little
Ah - well now that makes much more sense. You're going about this the wrong way. I'm not sure if you've checked out the Sibelius tutorial videos, but the main point you need to grab onto is that you no longer have to manually load your instruments into Kontakt Player. Using Sibelius's ";Instruments"; feature (whether you need to change instruments or not) will automatically load the instruments into the player for you, and ensure that correct mapping is set. You have to carefully follow the correct procedure for this to work. If you try to manually intervene, something will probably go haywire - which I'm sure is what you're experiencing at the moment.

The video tutorials are at:
https://www.tapspace.com/support/tutorials/Sib51.html

I would recommend you pay particular attention to step 3 and 4, but there is valuable information to be gained from carefully digesting all of them.
Jim,

    Thank you for your response.

Let me take you through what I'm doing point-by-point. I'll try to be as specific as possible.

1. The files on which I'm working are original to Sibelius 5.1. I'm not trying to play anything back that I began/completed in Sibelius 4.

2. The four or five files that I've started in Sibelius 5.1 are for battery instruments, only. I've not had to do any instrument changes. I'm writing for snares/quads/bass/cymbals, and that's it.

Here are my steps that I take when loading KontaktPlayer2 (after opening the program.) This is all done out of the Virtual Drumline 2.5 menu on the left side of the KontaktPlayer2 interface.

1. Instruments > Drumline Battery > Snares > Snareline Manual
2. Instruments > Drumline Battery > Tenors > Tenorline Manual
3. Instruments > Drumline Battery > Basses > Bassline Manual
4. Instruments > Drumline Battery > Cymbals > Cymbal Line All

I'm using my M-Audio O2 keyboard that I bought from you in 2005. Uh, that's all I can think of now. I'm worried that I'm about to reach my intellectual capacity, here. The product is smarter than I am, I'm afraid.

Again, thank you for all of your help.

Matt
[quote author=Matt Little link=topic=2440.msg13183#msg13183 date=1211215210]
It's been too long since I've started trouble around here, so here we go!

I've loaded the VDL 2.5 Bassline Manual Lite sound into Kontakt, and I still don't get all the correct sounds.

As I've started messing around with it a bit more, I've discovered that the Keymaps aren't yielding the correct sounds upon entry.

- 6"; drum shots are on the correct ledger line, but sound as 12"; drum shots

- snare ping notation is now a circle with a dot in the centre on the ";C"; space, as opposed to an X on the ";B"; line

- All regular snare hits enter on the ";C"; space, instead of the ";A"; space from VDL 2.0).

Again, I apologize. No; seriously. I mean it.

Matt
[/quote]

Matt - most of these things are correct. Have you been referring to the ReadMe that comes with the template? You'll see that snare notation (including regular staff space and ping shots) are different than they were from the Sibelius 4 templates. As discussed in other previous forum topics, it's best [i]not[/i] to use the Sib5 template to attempt playing back older scores that were created with Sibelius 4 (not sure if that's what you're trying to do).

Regarding not hearing the correct sounds - without any details, all I can do guess one of the two following things:

1) You're trying to play back a score that didn't originate from the Sib 5 template.

2) The instrument changes in your score aren't correct. I mentioned this to you earlier. Realize, when inputting instrument changes, you must choose instruments from within the VDL 2.5 Instruments family. If you use one of the preinstalled ";Marching Bass Drums"; or something of that sort, it won't likely work very well as they're not specifically programmed for VDL.

Beyond that, I'm not sure what to suggest. You may get better answers if you actually spell out each exact step in absolute detail, step-by-step. Otherwise, all we can do is guess as I have done above. As you'll probably find out, the degree of helpful information and answers you receive here will be relative to the amount of information you provide.
It's been too long since I've started trouble around here, so here we go!

I've loaded the VDL 2.5 Bassline Manual Lite sound into Kontakt, and I still don't get all the correct sounds.

As I've started messing around with it a bit more, I've discovered that the Keymaps aren't yielding the correct sounds upon entry.

- 6"; drum shots are on the correct ledger line, but sound as 12"; drum shots

- snare ping notation is now a circle with a dot in the centre on the ";C"; space, as opposed to an X on the ";B"; line

- All regular snare hits enter on the ";C"; space, instead of the ";A"; space from VDL 2.0).

Again, I apologize. No; seriously. I mean it.

Matt
Thanks Jim.  I am patient, but I need to learn to check out these forums before I update Sibelius!  I think I have it all working now, and just in time...2 shows to write!
On Mac, really all you should need to do is drag the Sibelius application to the Trash, and empty the trash. There may be some preferences lingering, but I don't think they'll negatively affect your reinstallation of 5.1 from the DVD. Sorry for the extra hassle. We're working on the 5.2 fix, but as always, there's a bit more to it than simple tweaks. Hang in there!
So, from reading the threads about Sib 5.2, I suppose I need to uninstall Sib. 5.2 and reinstall 5.1 from the DVD.  I know this should probably be asked on a Sibelius forum, but what is the most painless way of uninstalling Sibelius on my Mac?  I am running 10.5.2.  Any advice is appreciated!
Be sure you're using one of the Bassline instruments from the ";VDL"; family. If you use the ";Marching Bass Drums"; instrument (preloaded with Sibelius) you won't get good results. You can reassign this (if it's incorrect) by performing an ";Instrument Change"; at the beginning of your bassline staff.
Jim,

Thanks for the help. I did what you suggested, and everything seems to be working fine in terms of note entry and such.

However....

My bass sounds seem to not be working properly. Bass four and five are the same pitch, as are basses two and three. Also, my bass drums don't play back with the other instruments, sometimes.

Thanks!
Matt
For starters, I'd recommend you downgrade to Sibelius 5.1 until we can get the VDL template updated. The link that southerncomfort posted will explain why. To do this, you may need to completely uninstall Sibelius 5.2 from your machine, then reinstall Sibelius from the Sibelius disk. Once that's installed, if you're on 5.0, you'll need to update that to 5.1 using the link found in the previously mentioned link.

That probably has nothing to do with your problem though. That's a separate issue.

If you aren't seeing KP2 from within Sibelius's Playback Devices window, you may not have the KP2 plugin properly installed so that Sibelius will recognize it. I'd suggest you start by reading this note from their help site:
http://www.sibelius.com/cgi-bin/helpcenter/show.pl?id=537&languageid=1&searchid=2198535

Hang in there. This will all probably start to make more sense as you gain more familiarity with the software and how your computer needs to interact with it.


Jim,

Thank you for your response. Here's my system:

Windows XP Service Pack Two
Dell Latitude 630
T7250 @ 2.00 GHz
777 MHz, 1.00 GB of RAM
VDL 2.5 with Sibelius 5.2

I have Kontakt/VDL installed to the point where the interface comes up where I can load all of the instruments. Do you think I may have skipped something?

Thank you for your patience. You're the best.

Matt
Hi Matt,

It's hard to know what you may or may not have done. Can you give us a more accurate description of your steps, and the system you're doing this on? At first glance, it sounds like you may not have the Kontakt Player plugin installed.
Login or Signup to post a comment