Voices Dropping Out

I'm going to try to be as detailed as possible, so this may be a bit long, and hopefully coherent since I just took a pain pill for having a wisdom tooth jerked out of my head this morning.  :)

First off -- I'm using Sibelius 5.1 with VDL2.5 on a Leopard iMac with 3 gigs of ram.

Last night I was working with a full indoor percussion score (full front including synths, bass guitar, etc and battery).  I had no problems until last night, and it had been a month or so since any previous work had been done on the file.  I started experimenting to see if my system could handle a full score of the ";full"; instruments and not the ";lite";.  It has handled other files ok, but not a full percussion score yet.  When I loaded up the full versions, I noticed a few battery voices dropping out at the end of a fully scored phrase.  So I decided to check my Activity monitor and it appeared to me that I should have easily been able to pull that off, having around 500 megs of ram unused. 

So now the list of things I tried to isolate the problem -- made sure nothing else of significance was running; saved and restarted Sibelius in case some unused samples were still hanging around; tested switching heavy delay voices (vibes, timp) back to the lite versions; and I also started with the battery voices and then went up the score adding a voice to see how far I could go before losing anything.  Here's my score list -- Chimes, glock, xylo, marimba 1 and 2, vibes 1 and 2, synth 1 and 2, timp, bass guitar, rack combo, metal combo, snare, tenor, bass, and cymbal.  I could basically hear everything until adding the last voice or two.  In other words, going up the score I could hear everything until I added the glock part.  If i left out two voices, it was fine.

So I thought somehow I was running out of voices, so I checked and made sure that I had two instances of KP2 active in the configuration and I did.  So for kicks I added a third instance of KP2 and a second instance of Sibelius Essentials, again trying to isolate any and every issue.  No change.

So after all that I switch everything back to the lite version, save and restart, and it's still happening.  What's even stranger -- if i start playback in the ";bar of lost voices";, everything plays back fine.  If I start one bar before, it's fine.  Any farther back than that and I lose the voices.  I've done everything on my own that I could think of, and nothing turned up in my search of the forums (if i used the right search words).  If it's something I've overlooked that's right there in front of me I apologize for missing the obvious. 

One more thing, the only thing I have changed recently is updating Leopard to 10.5.4.  I would think that this really doesn't have anything to do with it, but then again if there's anything I've learned around here is that there's no such thing as too much detail when isolating a problem.  Thanks in advance.
Ditto what Jesse said on the RAM. Dropouts are often issues of CPU/DFD streaming during dense sections.

Lowering the release knob may help. Since you seem to have zeroed in on the glock part as a possible culprit, maybe start with that. One way to ensure Sibelius lowers the release knob on that instrument each time you open your file is to enter the actual MIDI message into your score (on a per staff basis) as follows:

~C20,1

That will bring the release knob all the way down. If that's too short of a release for your taste, you can increase the ";1"; to something of a higher value. 127 would be all the way up. I'd also suggest doing this on your vibes, chimes, and marimbas for good measure.


Thanks Jesse.  I will definitely adjust some settings and report.  It's still odd to me that this just started happening.  When I originally wrote the file this issue didn't exist.
Just because you have some spare RAM left doesn't mean your computer can handle more instruments.  That's not how computers work.  If that were the case, than all computers would be able to playback a massive orchestral score with just a RAM upgrade.

You're probably hitting your max polyphony and adding instruments with long sustain like cymbals, glock and vibes are causing others to drop out.  If you dial down the Release of those instruments, you'll be able to hear more notes before things drop out.
Oh man, if that fixes it I'm really going to feel like a putz.

I'll try that.  Thanks Tyler.
I'm not a Sibelius user, but I know Finale can get pretty horked if you update your OS and don't do a full restart of the computer.
Login or Signup to post a comment