Program Changes and Mapping

Mac OSX 10.4.11
Finale 08 b
VDL 2.5
M-Audio Keystation 49e

I have the VDL 2.5 Finale 08 template that I have added horn parts to from another finale file. I am trying to switch between taiko drums and regular battery drums in the beginning of my score and can't get the sounds and note mapping correct.

I have loaded an empty bank, set it to channel 1, drug the snare line and taiko patches into it. I then used the expression tool to make a ";to taiko"; text instruction and went to the playback screen to do a program change. I chose patch, program change, 2 in the highlighted box. Went back to may score, put the expression in and still only snare sounds. I played around with all of the choices there are in the program change drop down, and nothing happened. I also tried the MIDI tool. Chose the patch button, highlighted the measure, clicked the ";set to"; to the 2nd channel for the taiko, and still nothing. Could someone please help me with this?

After deciding to just use the layers to change the sounds and get on with life I realized that my mapping was way off for the taiko drums. Went to the staff definition, chose all the notes that were listed, and applied it. Notes were still in crazy places, and had strange noteheads. I went back to the VDL template, saved the library, imported it into my score, and still the same.

Thanks in advance for all of the great support of this product. I usually answer all of my own questions by reading this forum, but I am officially stuck.
You would want to look into the Staff Tool and using Defined Staff Styles for the mapping change.

1) Select the Staff Tool
2) Under the Staff Menu, select Define Staff Styles
3) Make the proper settings in the Staff Styles box (change the Style to Percussion, and load the Taiko map)
4) Make a selection with the Staff Tool
5) Under the Staff Menu, select Apply Staff Style
6) Select the Staff Style you created

Now that we have the mapping set correctly, it might be easier for you to do a channel change to get the playback set.�� With the Expression Tool, create a new expression.�� Choose Channel for playback type, and select channel 2 under ";Set to Value"; (or whatever channel you have the Taiko Drums on).
I'm pretty sure I did all of that stuff.

I know I defined the staff style to percussion, chose the taiko map, highlighted all of the notes, but they are still weird looking note heads, and not in the right places on the staff. When I select the measures that I want I click apply, and choose the taiko staff definition. Do I need to go in and map everything that I will use for this score from scratch, or should I just try to start over and see if that does anything?

I also went back and redid my bank. Empty bank, drug the two instruments I needed, text expression, playback, channel, 2. Still only playing the instrument in the first slot.

Am I missing something? Is there a setting in my system that may be wrong?

Thanks again for all of the help.
When you add the expression, are you using a measure or note expression?  If you used a measure expression (green), try switching to a note based one (red).

Did you write your music first then apply the map?

Just ot be clear that when you are doing a Program change in Finale with an Instrument Bank that you have setup, you will need to be choosing PATCH as the Playback Type and then BANK SELECT 0, PROGRAM CHANGE.  You will have to fill out >2< numbers here.  Make sure that the BANK SELECT NUMBER basically is the channel number that you are on.  So, if your Snares are on channel 1 with an Instrument Bank, then this will say 1.  Then the Program Change is the slot where you loaded a particular sound.

I would always do the Staff Style Change first before entering the notes that have a different mapping.  This does not work so hot when entering them and then changing the Mapping...A good example is a doublestop with TAM and BD.  The notehead types do not come across correctly.  ONce changing the mapping, make sure that you are actually entering the notes into the right location on your keyboard so that the come across right.  I always have to refer back to the manual's keymaps to make sure I am hitting the notes in the correct octave.

Also, what Justin said.  I would use a Note Expression and then if you add it to the Beginning of Measure, this may playback better.  Measure Expressions are not something I would suggest using with Finale and VDL - ESPECIALLY not with Human Playback.
Login or Signup to post a comment