crash and burn

been writing for 3 days with my Sibelius 5 update, and my newly purchased VD 2.5. This is the first time I have used the software, but have been using Sebelius for quite some time. It is truly awesome.

I am writing a large concert ensemble piece with many rack percussionist. Went along great for 4 days learning new things, trouble shooting was relatively easy, then out of the blue BLAM every time I upload Sibelius, and kontaktplayer2 is uploading the VD sounds, I get this message (could not allocate DFD memory (not enought memory available) Audio engine will be stopped).

The score will pull up and I can navigate around the score, but as soon as I ask it to playback anything, wether it is using the playback commands or just clicking on a note, I get this message (The instruction at 0x03f8ee94 referenced memory at 0x00000040. The memory could not be ";read";)

I am using a school computer that I just did some serious upgrades on. I am using Windows Xp, and my computer now has 8gb of ram. I am using Audiophile 2496 M-Audio, I have to believe this can't be a lack of memory. I have messed around with the audio setup, change the amount of ram usage in Kontaktplayer2. This happened so suddenly.

By the way, it happens with other scores as well that I use in conjunction with VD and KP2.

Any help will be appreciated. We have our first show in 3 weeks and I procrastinated to long already!!!!!. :)
Just a heads up about system RAM. In 32-bit systems (i.e. standard Windows XP, Vista 32-bit, etc.), the max usable RAM amount is somewhere between 3 and 3.5 GB. I happen to use 4GB, and I know I'm not making use of all of it, but I'm making use of almost all of it.

In order to make use of 4GB of RAM or more, you need a 64-bit operating system. This can be Windows XP64, or more likely Vista 64-bit. RAM is ridiculously cheap these days, so it's probably not that much of a financial hit to shove 8GB of RAM into a Windows XP machine. But you're not getting anything out of it.
Jim, I don't know how you did it, but you were right on everything. Thanks a ton. It is working great! I love this stuff!
Hi David - If you haven't already, be sure to update to VDL 2.5.1. Running this updater will also update your Kontakt Player to 2.2.4 which should generally function better.

I'd also recommend you remove ALL instruments from your Kontakt Players. For example, if you have 3 instances of KP2 loaded into your playback configuration, select each one, click the ";show"; button, the in KP2 click the ";load save"; button and select ";reset multi."; You'll notice once you do this, any loaded instruments will be removed from the rack. Do this in [i]each[/i] instance of KP2. Once you've done that, SAVE your playback configuration before leaving the ";Playback Devices"; window.

Another thing, I'd recommend is to go into your Sibelius Preferences>Playback area, and select the box that says ";When starting Sibelius, load this playback configuration"; - then set it to a configuration that uses no active instances of KP2. This will greatly increase your launch speed when starting Sibelius. You will, of course, need to switch to a playback configuration that's been created to use KP2 and the VDL Template sound set. This would be the configuration I was discussing in the previous paragraph.

One other thing that may help if your problem is DFD based. Quit Sibelius. Then launch Kontakt Player 2. Click the ";Options"; button, then select the ";DFD"; tab. See the slider? Try adjusting this. There's no target I can recommend for you here, but this can make a difference on how much memory is being allocated for DFD. Maybe try lowering it down to around 6MB, then do some trial/error testing. Once you've done this, quit KP2, then launch your Sibelius score and see how things perform there.

Keep in mind, just because your machine has 8GB RAM doesn't mean Sibelius is going to use it all. Unless you're using a 64-bit system, most programs won't be able to access any more than 2GB RAM at once. You may want to launch your task manager to view how much memory is being consumed by Sibelius when running this score.

Hope some of these suggestions are helpful for you.
Login or Signup to post a comment