Playback picking up other channels

I've asked a few people to help with this issue and no one has been able to remedy the situation. I'm using Finale 2009 and VDL 2.5. I've set up all of my channels correctly. When I input my drum set part, I hear all of the correct instruments via midi keyboard input. However, when I playback, it's picking up other channels for some reason. I've gone through and checked that all of the channels are assigned correctly and they are. I've found and muted the instruments that it's picking up, but I still can't get it to recognize the channel that it's assigned to. Any help would be greatly appreciated!

Brandon Estes
Welcome to the forum, Brandon!
Thanks for the suggestions Jim. Those are all remedies that I'd already checked and still no dice. I've just started a new score. It seems to work now. I'm not quite sure what was wrong with the older score. Thanks anyway.

Brandon
Since you're on Finale 2009, I assume you're using Kontakt Player as a plugin (not in standalone mode). Assuming that's the case:

You mentioned that your channel settings are correct, but it sounds like maybe they aren't. Just in case, double-check to make sure that the channels set within Kontakt Player are set to the same channels set within Finale's Instrument List.

Also, remember the Finale breakdown for channels in different instances of Kontakt Player:

[i]PLAYER INSTANCE#) KP CHANNEL = FINALE CHANNEL[/i]
1) 1-16 = 1-16
2) 1-16 = 17-32
3) 1-16 = 33-48
4) 1-16 = 49-64
etc...

Also be sure that no instruments within Kontakt Player are set to the OMNI channel which will pickup midi input from any channel.

Another thing you can do to test things is to set one of the non-drumset staves to ";solo"; in Finale, and see if it's triggering the expected channel from Kontakt Player.
Login or Signup to post a comment