Kontakt/Devices issues in Sibelius 6.1

I've searched all over the forums and have found similar problems (the most similar linked below). But I still can't find an answer.

I've been writing a lot over the past several weeks without any problems, and today I open Sibelius 6.1 to find an error message that reads: ";Audio Engine Error: bad settings";. I've never seen it before. I checked in the Playback Devices window to find that the only available devices are my MIDI keyboard and the IAC Driver. No Kontakt. I get no playback at all in Sibelius. The odd thing is that everything was there and working great 2 days ago, and I've done nothing new to my computer since then.

I checked and found that the ";kontaktplayer2.component"; is in its correct location. The Virtual Drumline xml file is where it belongs. The nkc and nkl files are where they belong. My playback configurations are still present in my devices window (though nothing shows up in ";Active devices"; when I select a configuration) and in their correct folder on my hard drive. Anyone have any ideas?

The link below is a similar problem, but didn't seem to solve my problem. I'm running Snow Leopard (just upgraded a week ago, but Sibelius has worked fine since then) on a MacBook Pro.

This is actually a Sibelius issue, not necessarily related to VDL. 

You can try trashing the 'PlogueEngine' folder in /Users/[your username]/Library/Application Support/Sibelius Software/Sibelius 6/ and then restarting Sibelius.

This can happen sometimes if you've run Sibelius in ReWire mode or have connected/disconnected any sort of audio hardware.

If all else fails, you can disable ReWire altogether (assuming you don't need it) by moving the ReWire Shared Device.dll out of the way, e.g. move it from the 'Sibelius 6' folder to a folder called something like 'ReWire (disabled)' that yo create yourself - as a sort of holding place.
Thank you Bryan.

Trashing the ";PlogueEngine"; folder didn't do anything, but then I removed the Rewire device from its folder and that seemed to do the trick. I had to go back and readjust a few things in the Devices window again, but it's working fine now.

As to the cause, I realize this is a Sibelius issue, but do you know specifically what could cause something like this to happen? I occasionally use Garage Band at the same time as Sibelius but not in Rewire. And I do recall getting some sort of error message in GB last week about audio (don't remember what it was). I just want to make sure I avoid the same problem in the future if possible. Lastly, if I want to use Rewire in the future, do I just put the file back in the shared folder from which I removed it?

Thanks again for your help.
No problem, Brian.

The fact that you were running GB with it might be the problem.  GB can be run as a ReWire host, so having them running together, especially if you ran Sibelius then GB.  I'm not entirely proficient on the inner workings of ReWire, but this could have been the root of the problem. You [i]can[/i] actually sync GB and Sibelius by starting GB then Sibelius.  Sibelius will sync to the tempo and clock of GB. If Sibelius is starting in ReWire mode, the playback window appear like the attached image.

I used to get that ";Audio Engine Error"; message sometimes upon starting Sibelius if I would have have another audio application such as Audacity or Sonar running, but that was on my Windows machine.  Haven't seen it at all since moving to my Macbook Pro as well, also with Snow Leopard.

Something else that might be worth trying is moving the Rewire file back to the original location, then go into Sibelius and see if you are able to Clean up the Rewire mess via [b]Play > Playback Devices > Audio Engine Options > Clean up[/b].

Glad we sort of got you back on track.
So I've been working the past several days, and all has worked well, but I managed to make the same issue come up again this morning. I am pretty sure it came about again by running Garage Band, though I am not running the programs in ReWire mode. I can't remember if Sibelius was even open when I opened GB. For the ReWire to work, I know GB has to be open first. In any case, Sibelius worked fine since then until this morning when I go to open it up, and I get the ";bad settings"; error again. I trashed the ";Plogue"; folder...nothing. The ";sibelius.rewire"; file is still where I put it the other day (disabled). I don't get it. Any advice? Thanks!
Did you try the suggestion I made in my last post - Clean Up (under ReWire)? I was actually able to duplicate the issue you described by doing the following:

1) Start Sibelius
2) Start GarageBand.  As you mentioned Sibelius won't be in ReWire mode, since the host (GB in this case) has to start first.
3) Close Sibelius and GarageBand (doesn't matter in what order)
5) Start Sibelius - At this point, I also get the ";bad settings"; error message.
6) To fix, go through the Clean Up process.  Should be good to go.  Note that you should be able to do this without opening a score.  When Sibelius opens, just close the Quick Start, then go through the process.
7) Restart Sibelius - everything works fine again.

I've reported this to the folks at Sibelius.  However, all other DAW are able to work fine, without any ReWire issues, so I'm not sure what might be causing it.
When I posted my last message, I had tried the ";Clean Up"; function, but it didn't fix anything on the next startup of Sibelius (after I quit a restarted), but I just tried opening Sibelius again (after taking no action since the last ";clean up";), and it works fine. I guess it takes a minute or something. Anyway, I will probably just avoid opening GB while working in Sibelius for now, but at least I know how to take care of the problem if it does arise again. Thanks so much!
Eureka - success at last! Glad that we finally got you squared away, Brian.  I'm not sure if there is any sort of time delay, but were both Sibelius and GB closed when you reopened Sibelius? And did you put the ReWire file back in its proper place before restarting?

Regardless, a solution is a solution, no mater how you slice it.
Login or Signup to post a comment