Sibelius Staff Text conflicts: Rim and Stick et al

Having recently dealt with a few issues regarding how some staff text styles (e.g. technique, small, boxed, etc.) interact with VDL, I figured I'd post a general thread that will hopefully be helpful for future troubleshooting.

If for some reason you start experiencing weird playback on a staff, and are confident that everything is configured properly, check to see if you have any staff text that might be the catalyst of the problem.  Some examples are (regardless of case):

";Rim"; on the SnareLine and TenorLine instruments causes all following notes to be rim notes.
";Stick"; on Marimba instruments causes all notes to roll.

I'm sure there are more, but just wanted to post this as a sort of Surgeon General's warning: placing the text ";stick"; on a marimba staff could be hazardous to your playback.  The proper way to deal with them is to select the text in question and uncheck the ";Play On Pass"; boxes in the Properties window, under the Playback heading. This will ensure that the text has not effect on the music/staff on which you have placed it.

Hopefully this will prove helpful for some of you in the future.
Just to avoid confusion, ";stick"; causes rolls on the marimba, but ";sticks"; resets the marimba to the proper sound.

I didn't realize that the ";play on pass"; Sibelius properties applied to technique text like that (i.e. that the text will be ignored if you uncheck the boxes). There perhaps is an application in there for techniques that change on a repeated passage.
Thanks for clarifying, Joe. 

Yes, any staff text will be ignored if the Play On Pass boxes are unchecked.  That is very true, that you could perhaps have a person do dead strokes on a marimba the first time through, but normal strokes on the second.`

Does anybody else have a list or an addendum you coud make to my very short list of technique text conflicts?
Per [url=https://www.tapspace.com/forums/index.php?topic=3801.msg20085#msg20085]this thread[/url], the text ";high";, ";medium";, or ";low"; can cause different marimba techniques.
Another one I just discovered is the text ";rolls";, when used in conjunction with the FP (forte piano) roll on the SnareLine instruments, creates a nice machine gun effect. As per the initial post, turning off the Play Pass for that text fixes the issue.
These posts are somewhat helpful.  But if I choose a specific not, for example in the TenorLine, to be a RIM sound, how can I have that RIM sound be played back without effecting all of the notes that follow afterwards?
[quote author=Smileysnare link=topic=3511.msg20456#msg20456 date=1291613663]
These posts are somewhat helpful.  But if I choose a specific not, for example in the TenorLine, to be a RIM sound, how can I have that RIM sound be played back without effecting all of the notes that follow afterwards?
[/quote]

All you have to do is change the notehead number. For TenorLine rims this would be either notehead 1 or 40 (R and L).

Staff text is not required for TenorLine shot/rim/dread/rod sounds. Review the Readme, especially the dictionary list and mapping diagrams for more.
I'm not sure I even know what you're talking about when you say change the notehead #.  I've never dealt with notehead #'s at all.  I use an M-Audio 25 key MIDI keyboard.  I use this to input the sounds I want.  I've read all of the tutorials, read me files, etc etc.  They all explain how to input the sound.  NONE of them explain how to lock that sound in.

If I assign a RIM sound to a specific note, then EVERY note in the rest of the piece is a RIM sound.  I only want that one and only note head to have a RIM sound.  How do I accomplish that?
OK dude this helped me.  Thanks!!!!

I do have on other issue that has come up now.  I understand how to change notehead #'s, and I understand how this allows playback to be accurate.  For the left hand RIM notes, I wanted to add some text above the note as instructions for the performer.  The RIM notehad looks similar to a Rim SHOT notehead, so I wanted the text to be there so they knew the left hand was supposed to be on the rim.
I chose Create, Text, Other Staff Text, Plain Text.  The text I typed was ";LH on rim.";  Now I'm right back where I started.  Every note after that text is now a rim sound on playback.  I even checked the notehead #'s for the notes that happen after and they are all assigned the correct notehead, yet are being played as a rim sound.

How do I avoid this?

It's ironic that you keep asking the same question, since you're posting in a topic focused around this specific issue. If you'll read my first post in this thread, I gave instructions on how to fix the problem.

Hope fully that will solve your problem.
And what exactly was the solution to the staff text problem? ...

[quote author=Bryan Harmsen link=topic=3511.msg18458#msg18458 date=1263957223]

[b]The proper way to deal with them is to select the text in question and uncheck the ";Play On Pass"; boxes in the Properties window, under the Playback heading.[/b]

[/quote]


I suppose you don't even have to use staff text at all. There are other text options that could be used that won't affect playback.
First I'll respond to Bryan

I actually did a search, which is something you recommended to me before, regarding this issue.  I found a post within this thread.  I of course failed to scroll to the top and see your initial post.  Oops!!  My bad.

Also, the first question I had in this thread had nothing to do with Text.  It had to do with using the modulation wheel to get a RIM sound, which in turn caused all of the notes following to sound like RIMS.  That happened without putting any text above whatsoever.  I was unsure how to lock in the desired sound.  But chznvrt pointed me in the direction of the tutorial videos which helped tremendously. 

Ok now for chznvrt.

You and Bryan both were witty enough to point out my laziness.  I suppose if I take the time to read ALL of the posts, especially the initial one for a particular thread, I would find some of my answers.  :-)  Don't forget, it's often MUCH faster to just simply ASK.  The amount of paperwork that comes with VDL and Sibelius is so overwhelming that I would still be searching for answers to questions I had months ago.  Thanks to the beauty of this forum, I can simply post a question, and someone will answer within a few hours.  That is MUCH more efficient that scrolling through hundreds of pages of instructions.  Of course I sometimes get the response, ";Read your ReadMe files, read your documentation"; etc etc.  Most of the time I'm lucky enough to get a straight forward response that is helpful.

So like you just mentioned, I may not have to use staff text at all.  What text options do I have that won't effect playback?  Or will I always have to uncheck 8 boxes every time I want to type in an instruction? 


Thanks!!!
Smileysnare - Keep in mind that the ReadMe and any other PDF documentation you get with Sibelius or Virtual Drumline are also [i]searchable[/i]. This is awesome, because as long as you know what your question is, you can type some key words into the PDF's ";search"; field, and oftentimes find your answers that way. It's kind of like asking, but without having to wait for someone else to get around to responding. The important thing is knowing what question you're trying to ask. Sometimes that's the main challenge. :)
[quote author=Smileysnare link=topic=3511.msg20463#msg20463 date=1291661703]Or will I always have to uncheck 8 boxes every time I want to type in an instruction?[/quote]Two clarifications are worth mentioning here:

1. Unless you have repeats in your music, you only have to uncheck the first ";Play on pass"; box to achieve the desired (non)effect.

2. Only certain text causes effects that can be undesired, and then only on certain instruments. For example, I just wrote a piece that had numerous staff text entries (i.e. ";Enter stage left behind bass drum player";) and this text did not affect playback at all. There are only a few words that cause playback techniques to change (and this thread exists to identify them), and when that happens you can disable this technique change by following the instructions in this thread.
I just wanted to post a notification here that some of you may find very surprising. 

I ran into an issue when adding an expression to a note.  I inputted a note using the ";Dry Crush"; sound using Snareline Manual.  I wanted to place the Tremolo sign ";Z"; to that note.  I discovered that on playback, the Dry Crush sound was no longer being played back.

Ok so here is the notification that may be hard to believe.

I was able to problem solve this all by myself!!!!  I didn't have to come to this forum and start asking!!!  yay!!!!!

I just wanted to say thanks to all of you who have helped me along the way.  It's been an interesting ride, but well worth it in the end.

;-)

By the way, here's how I fixed the problem.  I selected the tremolo ";Z"; symbol, and in the Playback controls window, I unchecked the ";Play"; option next to Tremolo.

:-)


Login or Signup to post a comment