Sibelius 5.4 template?

Hey all, quick question

Will the Sibelius 5.2.5 template work with Sibelius 5.4?  I had to update to 5.4 to solve the issue of the mixer shutting down Sibelius in Snow Leopard.  Just wanted to make sure the template would work before I bought it. 

Zach
Thanks for bringing this up, Zach. We've just updated the product page for the 5.2.5 template to verify that it's compatible with Sibelius 5.4. Should'a done that a long time ago! :)

Thanks again!
Thanks again Bryan!
Yep - the Sibelius 5.4 update was released almost entirely to fix that Snow Leopard issue.
Login or Signup to post a comment