Keyswitch not working

Sib 6 / VDL 2.5 / Template 6.0a / Kontakt 4 (not just the player)
Horn/Battery score ... VDL2.5 - Kontakt 4 for drums / Sib Essentials for horns
Computer keyboard note entry (no midi device being used)

Problem: Keyswitches for TenorLine (AutoRL)

I've got music that switches between regular sticks and puffies. I've been entering text ";Puffies"; and ";~nat."; to switch back and forth. Everything was working fine. Then, at some point where I was tweaking things and adding sticking, it got locked on puffies permanently.

I tried setting text ";~nat."; and ";regular"; and ";~C0"; and even adding note C0 at the very start of the score for the tenors. Nothing would change it back to regular sticks.

I checked Kontakt and the keyswitch was set to D-0. I change it to C-0. The music then played back correctly... until after it got to the puffies part. After that, it was permanently set back to puffies throughout the entire score. Starting from the beginning again (regular sticks) sounded like puffies.

I've had this sort of thing happen on occasion in the past. Any suggestions?
You're welcome, Mark.

It's been a long time since I've actually looked at that part of the sound set. Quirk or not, that's the way Sibelius handles switches that are setup the way I have them for the puffies (goes back to at least the 5.2 template). It'd do something similar if it was mod wheel settings instead of keyswitches. Even though you're pretty much the only one that has said anything about this in the last several years, my guess is that others have experienced the same thing occurring and just haven't mentioned anything about it.

I think I'll take a closer look at that in the sound set and see if I can't fix it up so it will behave a little more as expected. If I can, it will be applicable to the forthcoming version of the template.

Hugh
How about that. Seems so odd. I would have expected that setting ";regular"; at the start would have worked as well. Anyway, so it's not so much a ";problem"; as it is a ";quirk";. I can live with that. Thanks very much for your assistance, Hugh.
Hi Mark

Upon opening the file, it played as expected first time through. On second pass, I stopped the playback midway thru one of the puffies sections, went back to the beginning and I did get the same result you did - played back as puffies.

What you'll need to do to alleviate this is to let the puffies section play out so Sibelius will trigger the C0 ";regular"; keyswitch at the end of it. Once you do this, any other bar you select to start playback in should do so correctly.

Also, I was incorrect in stating that ";nat."; could be used at all in this case. Only ";puffies"; and ";regular"; will have any affect on those switches, with ";puffies"; being the main one that does any real switching (thus the instructions above).

If it still doesn't work for you the way I've described, let me know.

Hugh
Thanks Hugh. I appreciate your efforts.

I seem to recall reading (a very long time ago) that I was only supposed to select VDL 2.5 for that setting. Perhaps I'm confusing it with something else.

Regardless, I switched over to 6.0a (which was available in the drop-down) and the problem still exists.
Hi Mark. One thing I see immediately is that you don't have the correct sound set assigned in your Playback Configuration. All instances of Kontakt Player utilizing VDL need to have ";VDL SoundSet 6.0a"; applied. (The sound set version needs to match the Template version.)

If you don't have that available in the drop down list, you need to copy the xml file from your template zip package and paste it into your Sibelius user's folder. Review the Readme for the exact location for your system (or go [url=http://www.thewritescore.com/sibelius-templates-installing-a-soundset.html]here[/url]).

Then see if that fixes the puffies switch problem. If not, then I'll proceed with looking at the file you sent.

Hugh
I might be able to find it faster if you can send me the .sib file. Please include a screen shot of your Playback Configuration so I can try to duplicate the environment. (Sent you a PM so you know where to send it.)

Hugh
Did that when the problem started. No luck. Didn't add anything else to the start of the score. Double-checked by viewing hidden objects. Nothing else there.

Tried removing all text that stated ";puffies";. Problem still exists, and can't be corrected in the score, even by adding ";regular";. I have to go into Kontakt to correct it there. But if I add puffies just once somewhere in the tenor part, the permanent problem is back.
[quote author=corpcon link=topic=4215.msg22009#msg22009 date=1325452129]
I've had this sort of thing happen on occasion in the past. Any suggestions?
[/quote]

Double check that you don't have some other sort of Staff Text that could be messing it up. Try putting ";~nat."; or ";regular"; at the beginning of the score.

Let us know.
Login or Signup to post a comment