Sibelius 6 quit unexpectedly

This is the error message I am getting on my Mac. It just happened unexpectedly. I'm running lion and have all programs up to date.  The program first opens and then I get the color wheel of death when trying to playback. The program then quits and this eventually is the error message. The details show a host of what look to be library problems. 94 line items. Then it shows threads of dispatch, nsurlconnectionloader, etc. 22 threads. I also show binary images thereafter which go on forever. I own Sibelius 7 but have been apprehensive installing it without writescore.com's new template. In addition I will be presenting in a couple weeks on design and wanted to move around a program I am familiar with especially in my immediate preparation.  There are several sound libraries I regularly use besides vdl2 (mostly comb2, fanfare, absynth5, fm8).  Not sure if it matters but i have komplete6, kotakt4, aria player, and then the other players associated with each. I have run the disk utility already. Is there anything I could do that would be an easy fix instead of uninstalling and reinstalling everything? Help?  :-). Thank you in advance.
So glad to hear you're up and running again! Kontakt 5 isn't necessarily a good option if you're still on Sibelius 6 because it's not recognized as a Kontakt type AU, which would mean not having the auto-load functionality of Sibelius and Kontakt.

Good to know that the VST being in there was causing the issue. It must be a Lion-specific anomaly. Thanks for taking the time to report your findings here. I'm sure it'll help others in the future, which is what this forum is all about. Thanks!
The problem has now been solved.  Though, I wanted to at least post what I did in case anyone else has a similar problem.  I did try to change the playback devices to be only the sibelius player and had the same memory warning that ultimately would lead to a crash.  I also tried two separate interfaces and my sample rate was already set to the specifications that Jim suggested.  Unfortunately, the program was still crashing with the same error messages.  Sibelius told me that no version of Kontakt 4 is compatible with Lion and that I should upgrade to 5.  I found this to be unacceptable as I had been using both everyday for several months.  Sibelius then had me go into my hard drive library plugins folder and remove all kontakt plugins that had .vst as the extension.  I saved them in another folder on my desktop as I plan on still using those with Logic.  I will just reset what folder it pulls from.  I still had the same problem, but after the restart it has worked again.  I have worked on several scores now the past two days with no problem.  For some reason the .vst seemed to be causing the problem.  Not sure why all of a sudden it has happened.
Check out this thread for some troubleshooting I did on a ";PANIC"; error message.
https://www.tapspace.com/forums/index.php?topic=3736

I used to have this problem on my old computer with 4GB RAM, but once I built a new system with 8GB I don't think that I've encountered the error message since. Of course most of the other hardware changed in my new system, as did the operating system.
A couple things you might want to try in troubleshooting:

1) Change your playback configuration to use ";Sibelius Player"; rather than anything using Kontakt. See if you get a similar error.

2) Create a NEW Playback configuration using only one instance of Kontakt 4, and one instance of Sibelius Player.

3) Create a NEW Playback configuration using TWO instances of Kontakt 4, and an instance of Sibelius Player.

You may also want to check your ";Audio Engine Options"; in Sibelius, and verify you're using your desired interface, and set to a sample rate of 44100 Hz, with a buffer size of 1024 samples. Sometimes audio configurations can cause some wonkiness. It's a long shot, but worth checking out.

Do you have any other host programs (Logic, Garage Band) that you could try hosting a version of Kontakt 4 within? Just to check and see if you're receiving any memory errors there?
Jim,
I re-did the disk utility with your suggestion.  I verified and then repaired.  It did state a library file was unverified and set incorrectly.  Afterward I repaired.  I also verified the disk, and it said the disk was okay.  That new process did something where I could get into Sibelius briefly.  I always use the au version in my playback devices as I remember that was recommended on here somewhere.  By the way, the update of Kontakt is 4.2.4.5316.  When I went to play I got an internal warning on Sibelius that said PANIC: Could not allocate enough memory.  Program will become unstable.  I'm not sure why all of a sudden I am having memory problems.  I haven't done anything new, and have 8 gb of ram.  Then moments later it crashes with the same program message as before.  I can't post the error message here on the forum because it is way too big.
Hmm,

Have you tried this using the AU (Audio Unit) version of Kontakt rather than the VST version? Meaning, are you getting the same error regardless of which format of the plugin you're using?

When you say you've run the disk utility, do you mean you ran the ";repair permissions"; feature? That's different than ";verify permissions"; and running the former will actually fix any unverified permission issues where as the latter simply checks if there are issues. It's usually quicker just to assume there may be permissions that need repair and just hit the ";repair permissions"; option.

I'm also unsure what the error message is. Had you intended to include that in your first post?
Jim,
Thanks for the response.  I did update kontakt (also realizing the service center was no longer compatible on lion, and did the same there).  However, I am having the same error message in Sibelius.  I posted on the Sibelius forum, and they made the same reference to kontakt stating that was the problem.  Not sure what to do from here.  Any suggestions?
If you haven't already, you may want to verify you're using the latest version of Kontakt 4. I think it's more lion compatible at version 4.2.4. Update should show in Service Center if it's necessary.

Since it's a Sibelius crash, you may want to check with the Sibelius folks too.
Login or Signup to post a comment