Kontakt 4 / VDL 2.5.5 problem

The other night I purchased and loaded version 2.5.5.  At first I was getting a message that ";This patch was generated by a newer version of the application. Please upgrade your copy to load the patch.";.
This made me realize that I didn't have the latest version of Kontakt 4, so I downloaded that.
Now it works in standalone mode, but still doesn't work as a plug-in within finale.

I've re-copied the .dll files and pasted them in the VST folder for finale 2012, but this has not made a difference.

In stand-alone mode Kontakt says that it is version 4.2.4.5316.

As a plugin it says it's version 4.2.2.4504.

Any ideas what I need to do to make it function correctly as a plugin within finale 2012?
It sounds like the .dll plugin you copied was not the current one. Or, perhaps you copied it to the wrong folder. If you open Service Center, check to see that when you updated from 4.2.2 to 4.2.4, that the 4.2.4 VST plugin was installed (see screenshot). If so, copy that file (you can see the location via the Service Center), and place it into the Finale VST folder.

[u]For Finale 2011 and higher:[/u]
[b]Windows XP:[/b] [i]C:\Documents and Settings\All Users\Application Data*\MakeMusic\ Finale 201x\VST Support[/i]
[b]Windows Vista/7:[/b] [i]C:\ProgramData*\MakeMusic\Finale 201x\VST Support[/i]

[u]For Finale 2010 or earlier:[/u]
[b]Windows XP:[/b] [i]C:\Program Files\Finale 20xx\FinaleVST[/i]
[b]Windows Vista/7:[/b] [i]C:\Programs\Finale 20xx\FinaleVST[/i]

Also, if you see ";8out"; and ";16out"; versions of this in the NI VST Plugins folder, you should ignore them or delete them since you won't likely need those.
Oops. I just realized I never attached the screenshot. Sorry about that! Here it is.
Jim,

Thanks for the quick response.  I've checked, re-checked, and checked again that I've put the files in the correct place, but I'm still getting the same results.

I've attached some screenshots to show you what I'm seeing.  Screen shot 1 shows the NI service center, where I've copied the files to (MakeMusic>Finale2012>VST Support), and also shows the details of what version is present in that folder (4.2.4.5316 which is supposed to be the correct one.)

Screen shot 2 shows the version that comes up for Kontakt 4 when I use it as a plug-in within Finale 2012 (4.2.2.4504).

Screen shot 3 shows the version of Kontakt when I use it in Stand-alone mode (4.2.4.5316).

I am still unable to load any of the new library (2.5.5) into Kontakt when used as a plug-in.

As a temporary fix I'll just route everything to the stand-alone version, but I do really like to convenience of using it as a plug-in within finale and not having to start up and load two different pieces of software every time that I begin to write!

Thanks again for your help.
I'm not a Finale or Windows user, but perhaps Finale wants the 64 bit plugin to work? I see in the service center that it shows both 32 and 64 bit. Maybe try putting one in the appropriate place and seeing if it works, then the other? Just some thoughts.
Exactly. If you're not sure if you're running the 32bit or 64bit version of Windows, or whether you're running Finale in 32bit mode, the plugin you put in there may make a difference.
I am having the same problem. It is probably me, but I cannot get any sound in the stand alone mode either. I see from the sound meters on the stand alone player that it is generating output, but I cannot hear it on my laptop. I have checked the audio settings in the player, and made sure my laptop is outputting sound from other applications - but cannot get sound from the Kontakt player.

I also see one version (the newest) when I open Kontakt in ";stand alone";, but when I try to open it in Finale 2012a, it is an older version.

I know it must be me, but I'm frustrated!

David
Vita,

In Kontakt, try going to File>Options>Audio.  Then make sure that the correct device is selected for you audio.  I've had that happen before.

As for my situation, I've tried both the 64-bit and the 32-bit version of the Kontakt4.dll several times and it doesn't make a difference.  Also, if I'm not mistaken, Finale is only a 32-bit application, correct?  This would lead me to believe that the 32-bit .dll file would be the one that I would need.  I'm certainly not any sort of computer guru for that matter....

Thanks for your patience and continued help.

David/Michael:

If your Finale application is showing an outdated VST version for Kontakt, you may benefit from a clean slate. Start by [i]removing[/i] any current Kontakt.dll files from your ";FinaleVST"; or ";VST Support"; folders. Once you've done this, confirm that you aren't seeing any Kontakt availability from within Finale. If, somehow, Finale is locating those files from elsewhere, it's important you rule that out as an option.

David - if you're not getting sound in stand-alone mode, open Kontakt's preferences/options and go to the Audio tab to confirm your current soundcard is selected as the default output device. Assuming you're on Windows, you might also need to adjust the setting for the DRIVER as well. If you're unsure what this means, there's some information at this [url=https://www.tapspace.com/support/faq/index.php?action=artikel&cat=4&id=33]FAQ about soundcards[/url].

Michael - Finale 2012 is 64-bit compatible. You can find this information on the [url=http://www.finalemusic.com/Finale/System-Requirements.aspx]Finale website[/url]. Are you using the 64-bit edition of Windows 7?
Thanks for the tip. I took the time to render all other Kontakt related link files inactive. Also, oddly, my download of the latest KT player did not give me a 32 and a 64 bit dll option. Also, I closed Finale and restarted my system. Now, I can get the updated player to work as a plugin, but it will still not generate sound as a stand alone. Fortunately, I rarely use it as a stand alone!

I applaud the changes. As in any notable change, there is bound to be kinks.

Let's keep sharing and perhaps we'll ";iron them out.";

Thanks again,

David
Jim,

The clean slate was the way to go, I think I was figuring that out as you posted! Thanks for being so timely in responding. I truly appreciate your helpful philosophy with your VDL constituents!

David


[quote author=Jim Casella link=topic=4355.msg22848#msg22848 date=1336504516]
David/Michael:

If your Finale application is showing an outdated VST version for Kontakt, you may benefit from a clean slate. Start by [i]removing[/i] any current Kontakt.dll files from your ";FinaleVST"; or ";VST Support"; folders. Once you've done this, confirm that you aren't seeing any Kontakt availability from within Finale. If, somehow, Finale is locating those files from elsewhere, it's important you rule that out as an option.

David - if you're not getting sound in stand-alone mode, open Kontakt's preferences/options and go to the Audio tab to confirm your current soundcard is selected as the default output device. Assuming you're on Windows, you might also need to adjust the setting for the DRIVER as well. If you're unsure what this means, there's some information at this [url=https://www.tapspace.com/support/faq/index.php?action=artikel&cat=4&id=33]FAQ about soundcards[/url].

Michael - Finale 2012 is 64-bit compatible. You can find this information on the [url=http://www.finalemusic.com/Finale/System-Requirements.aspx]Finale website[/url]. Are you using the 64-bit edition of Windows 7?
[/quote]
Glad to hear you sorted out your plugins, David! Since Windows systems require you to manually move the VST files around, it can get a little confusing if you're not careful.

If you're not hearing sound in standalone mode, open Kontakt's preferences/options and go to the Audio tab to confirm your current soundcard is selected as the default output device. Depending on your audio interface, you might also need to adjust the setting for the DRIVER as well. You can find a little info about ASIO, WASAPI, DirectSound Windows driver formats in your VDL Glossary.

You may also need to confirm your audio outputs are properly assigned to your audio interface in Kontakt. You can read more about this in the Kontakt Application Reference (found in the 'Help' menu). See the screenshot to see what I mean.
Thanks for the help, Jim.  I think you are onto something, but I don't know where to go from here.  I have deleted all of the .dll files out of my ";VST Support"; folder and re-started my computer, and the old version of Kontakt still shows up?

How do I figure out where finale is getting that info from? I'm at a loss...

Michael - check your Finale Manual for ";Manage VST Plug-ins."; You'll see Finale gives you a way to check all the plug-ins it's referencing. In fact, using this, you might decide it's helpful to have it reference your actual NI VST folder as well if you wish.
Jim,

That was it!  Here is what I had to do to make it work:

1.) in Finale I went to MIDI/Audio>Device Setup>ManageVST Plugins.
2.) I de-activated all of the Kontakt 4.dll files.
3.) I copied the Kontakt 4.dll file out of the Kontakt 4 VSTPlugins folder.
4.) I pasted this into C:>Users>";Computer name";>AppData>Roaming>MakeMusic>Finale 2012>VST Support.
5.) Went back to MIDI/Audio>Device Setup>ManageVST Plugins and verified that it was active.

This all seemed to do the trick!

Thanks for your patience and help with this.  I really appreciate it!
Excellent! Glad to hear you're back in action, Michael!
Login or Signup to post a comment