Problems with VDL, MalletKat, and distortion

For last year's marching and indoor percussion seasons, our school has used a 4-octave MalletKat (without sounds), triggering a laptop hosting Kontakt 5 and VDL 2.5.5. I load the sounds for each show into Kontakt 5, running in standalone mode, assigned to specific MIDI channels, and the MalletKat triggers them.

A rehearsals begin for this year's marching band season, I am using the same setup, but for some reason that I cannot figure out, most of the sounds coming from the MalletKat are distorting. There is no distortion at low volumes, but at about anything above a dynamic of mp, things are distorting. This is happening for almost all instruments, low and high (chimes, timpani, vibes, etc).

Here is our setup:
MalletKat Grand without sounds
Dell laptop, Windows 7, 4GB RAM, SSD, VDL 2.5.5, Kontakt 5
Steinberg Ci1 USB digital audio interface
Mackie DL1608 mixer
2x EON315 loudspeakers

I have tried the following:

1. Checking gain structure. The laptop's output is maxed (I also tried lower settings). The input gain on the laptop's mixer channel is set appropriately so that max input from the laptop peaks about 5 dB below the clipping point. I doubt gain structure is the problem, anyway, because the distortion doesn't sound like it comes from clipping.

2. Trying a different loudspeaker. Same problem.

3. Connecting the Steinberg Ci1's output directly to a loudspeaker. Same problem.

4. Using the laptop's onboard low-quality analogue output headphone jack, either directly to the loudspeaker or to the mixer. Same problem.

5. Loading up Kontakt 5 .nkm multi files from the last two seasons, which previously worked fine. Although these don't trigger the sounds they originally were intended to, because MalletKat settings have changed. These also now trigger distorted sounds.

I am running out of options. I was thinking this was a hardware problem. Maybe it's a software problem. Reinstall Kontakt 5? Reinstall VDL on the laptop?
Hi Joe,

I might suggest checking out the tools in #4 at the link below, starting with #4.1. If you're getting any spikes, use #4.2 to try and isolate the cause:

http://www.native-instruments.com/en/support/knowledge-base/show/752/windows-7-tuning-tips-for-audio-processing/

I wouldn't think this would be an issue with the samples themselves, as the general cause of distortion issues is typically related to hardware driver incompatibilites, low RAM, latency, or a software problem with Kontakt. Since you updated the drivers and your computer's specs (at least on paper) should be able to handle this, I'd start down the latency route.
This may also be a long shot, but in the interest of continuing best practices, you may find these videos about optimizing a Windows PC for audio production helpful. They're a little geeky, but I guess we've already crossed that line. :)

Part 1 (where he says ASIO is preferred over WASAPI...maybe that's a hint!?):
http://youtu.be/P7awctTsK34

Part 2:
http://youtu.be/5Bla5vvQBG8

Obviously, proceed at your own risk, but I think there could be some helpful stuff here that I'm not well-versed enough to help you with. I hope so!
4GB RAM isn't very much these days. That was the spec I was referring to when I made the 'low RAM' comment.

I can't say for sure this is what's causing your problem. It depends on what other sorts of things Windows is doing in the background. Windows isn't always very friendly about this, and in my mind 4GB is sort of a minimum amount for simply running the operating system. Granted, that may be a bit of an exaggeration.

One thing I forgot to ask in my last reply is whether or not you're running Windows 7 in 32-bit or 64-bit mode. Which one you're using may affect which Steinberg driver you should have installed. I'm guessing you were mindful of this, but I wanted to mention it in case you weren't sure.

It may be worth opening your Windows Task Manager, and seeing what else it's doing in terms of memory allocation and CPU usage. I'm not nearly as experienced with Windows as I am with Macs, but maybe there's something there that'll shed some light on resource consumption.

Since your Steinberg interface has some software that allows you to dial in the interface settings, check that it's using a 44100 sample rate, internal clock source, and that any of its other settings match that of what you've set in Kontakt. If you can provide a screenshot of this window I might be able to make some other suggestions.

Did you fiddle with the preload buffer size I mentioned earlier? Do you have any different results if you drastically increase the latency slider in Kontakt?

Since you have an SSD, I would think this would be beneficial to your performance since laptops used to come with slow drives (to conserve battery), which could negatively affect sample streaming. Do you have any other specs on the SSD drive like what its read/write IOPS ratings are? I admit, I'm no expert here but I'm always a little wary of PC manufacturers who use cheap parts to keep costs down. That may not be what's going on, but it might be helpful to know more.

Sorry for the ongoing dialog here, Joe. I'm doing my best to think of any angle that could could affect your situation.
[quote author=Jim Casella link=topic=4745.msg24430#msg24430 date=1409002249]
I wouldn't limit the velocity settings on your controller because you'll essentially just be negating a lot of the expressiveness of the library by not allowing higher velocities to trigger.[/quote]Yeah... just looking for a fix.

[quote]I noticed the low amount of RAM on your machine specs. I'm wondering if that might have something to do with it. When testing, are you loading in several instruments, or just one instrument to check results? You might want to fiddle with the preload buffer size options in the Preferences (Options>Memory) area of Kontakt.[/quote]The machine in my signature isn't the machine involved in the discussion (although that has lots of RAM as well). The laptop in question is a 2.4 GHz Intel Core i3 with 4GB of RAM. That should be enough, right?

I'm loading in lots of instruments (a marching band show's worth).
Timpani (soft)
Timpani (medium)
Timpani (hard)
Chimes (MW)
Bells (hard plastic)
Crotales (med. plastic)
Vibes Hard (PED)
Marimba Rosewood (soft)
Crotales (bright)
Vibes Hard (MW)

Kontakt 5 Player says this is taking up 148.31MB when it loads. However, when I load up just a Chimes instrument, which is one of the worst distortion offenders, this distorts all by itself as well.

[quote]My hunch tells me this may have something to do with your audio interface or its associated drivers. You mentioned it's set to use an ASIO driver (for your Steinberg interface), or the ASIO4All driver (which I wouldn't recommend) for your built-in interface. First, check that you've installed the [url=http://www.steinberg.net/en/support/downloads_hardware/downloads_ci1.html]latest driver[/url] from Steinberg, and stick to testing it through this interface.[/quote]I'm using the latest Steinberg driver.

[quote]I'm also curious if there's a WASAPI version of the driver since that may be a more modern alternative to ASIO in the Windows world. Maybe something to research with Steinberg support.[/quote]WASAPI is listed with the Steinberg Ci1. I configured Kontakt 5 Player to use this, and restarted Kontakt, but the distortion is still there.

[quote]Any chance you have a different interface (and corresponding drivers) you can test with?[/quote]I do not.

[quote]Does your interface come with any other configuration software where levels are set? If so, check that these aren't set too high. That'd be the equivalent of the gain settings being overloaded.[/quote]Yes, there are some basic Windows-looking options. The line level output was set to 100. I changed it to 50, and then to 10. Things get quieter as expected. The distortion is still there (just quiet or very quiet).

[quote]Be sure Kontakt's sample rate is set to 44100. I doubt you'd have problems if it were set higher, but that may also depend on other aspects of your audio setup.[/quote]It's set to 44100.

[quote]If you play something through a different audio program, are you hearing similar distortion?[/quote]No.
I wouldn't limit the velocity settings on your controller because you'll essentially just be negating a lot of the expressiveness of the library by not allowing higher velocities to trigger.

I noticed the low amount of RAM on your machine specs. I'm wondering if that might have something to do with it. When testing, are you loading in several instruments, or just one instrument to check results? You might want to fiddle with the preload buffer size options in the Preferences (Options>Memory) area of Kontakt.

My hunch tells me this may have something to do with your audio interface or its associated drivers. You mentioned it's set to use an ASIO driver (for your Steinberg interface), or the ASIO4All driver (which I wouldn't recommend) for your built-in interface. First, check that you've installed the [url=http://www.steinberg.net/en/support/downloads_hardware/downloads_ci1.html]latest driver[/url] from Steinberg, and stick to testing it through this interface. I'm also curious if there's a WASAPI version of the driver since that may be a more modern alternative to ASIO in the Windows world. Maybe something to research with Steinberg support. Any chance you have a different interface (and corresponding drivers) you can test with?

Does your interface come with any other configuration software where levels are set? If so, check that these aren't set too high. That'd be the equivalent of the gain settings being overloaded.

Be sure Kontakt's sample rate is set to 44100. I doubt you'd have problems if it were set higher, but that may also depend on other aspects of your audio setup.

If you play something through a different audio program, are you hearing similar distortion?

Thanks for your patience in troubleshooting.
Hi Jim,

Thanks for the tip on how to trigger different velocity samples directly through the Kontakt on-screen keyboard. I tried this, and the samples still distort (quite a bit). Even if I turn down the volume of the USB audio interface connected to the laptop, there is a quiet sample, but still distorted the same amount. So, the origination for the distortion is from Kontakt on the laptop. This takes the MalletKat and the USB-MIDI interface out of the equation.

I'm still stumped. However, if high-velocity samples played back at a low volume are distorted, but low-velocity samples played back at a high volume are not, I can probably figure things out to artificially limit the maximum velocity that can be output from the MalletKat (I believe this is possible through MalletKat settings) and then crank the volume. Should I pursue this?
What happens if you trigger your sounds with either a regular USB/MIDI keyboard, or just using the on-screen mouse curser on the Kontakt keyboard? (You can get different velocities by clicking higher on a key for softer velocities, and lower on a key for louder velocities.) If that sounds as expected, my hunch is that this may be something related to the MalletKAT. If so, it might be helpful to verify by loading up some other velocity-sensitive patches into Kontakt (if you have any available) and see if they do the same thing - also double-checking that other controllers don't cause the distortion.

If you can whittle it down to a hardware issue with your MalletKat, it might be worth resetting it to its factory settings.

Alternately, if you're connecting the MalletKAT to your computer by way of a USB Midi interface, try updating the drivers for that device, or if you have one available, try a different interface to see if that's the culprit.
Hi Jim,

First I  updated Kontakt 5 Player. There was a large file to download, but installing it and rebooting the laptop didn't change anything.

Next I reinstalled VDL. I removed the library from Kontakt 5 Player, deleted the files from the laptop hard drive, reinstalled from the VDL 2.5.5 DVD, reloaded the Library into Kontakt 5 Player, and rebooted. No change.

Next I reinstalled Kontakt 5 Player. I downloaded the latest version from the NI website, installed, and rebooted. No change.

Running out of options... what's next?
That's definitely odd, Joe. And rather frustrating, I presume.

It certainly wouldn't hurt to remove the VDL library (from Kontakt, as well as deleting it from your machine) and then reinstalling it from scratch.

Before you do that, you may want to check Service Center and see if there are any Kontakt updates that you could run - just to be sure it's not an issue with the player.
Hi Jim.

Let's check these off:
Finale-specific instruments are not loaded.
Output audio still distorts using the onboard audio connected directly to headphones.
Latency is set at 512 samples. I experimented with 256, 128, 96, and 2048. I hear no difference in any of these settings, and the distortion is still there.

I still think this is a software problem.
Thanks, Jim. Will report back after rehearsal tonight. I doubt I am in the Finale-specific folder, but I'll check.

I do need to try headphones direct to the laptop. I didn't have any available while troubleshooting.

Kontakt is set to use an ASIO driver. That's either a ";fake"; one (ASIO4All output) when using the headphone jack, or a real ASIO driver when using the Steinberg Ci1. I will play with the latency, too (although this was tweaked when I first put this whole system together to minimize triggering lag while providing a stable platform; I found that going too low on the latency was resulting is output breakup, which necessitated a laptop reboot after only a few minutes).
Hi Joe.

Interesting. If it's a software problem, I haven't heard of it. My first though (and this is probably a long shot) is to double-check that you haven't accidentally loaded the VDL patches from the ";Finale Specific Instruments"; folder. I gather, since you're a Sibelius user, you wouldn't find yourself tooling around in there, but since the directory structure is identical to the main VDL instrument directory, it can be easy to forget you're in there. All those instruments have a considerably higher gain that could distort if you're running them in a non-Finale environment.

Another thing to double-check while troubleshooting: Hook up a pair of headphones to the onboard, cheap audio-out and see if you get the same result. If not, it might point to an interface/hardware setting or issue.

Have you checked the DRIVER setting in Kontakt? This would be in Kontakt's Preferences window, and essentially sets what sort of driver your audio interface is using. A cheap/bad driver can definitely be the culprit. While you're in there, also try fiddling with the latency slider and see if that jump starts any sort of different result.
Login or Signup to post a comment